Zotero citation refresh deleting Word document content

I am running Word for Mac (Word version 16.44, Mac OS Big Sur 11.1) and have inserted a bibliography using Zotero (5.0.95-beta.3+4db61b8dc). It has been working fine until I tried to update the bibliography with a new citation today - it seems that somehow part of the content of the document has become associated with the bibliography field code, so when the bibliography refreshes, it deletes that content. I assume this is what's happening because when I click on the problematic content, it highlights in the same color gray as the bibliography, and the content that isn't being deleted (even though all of the content contains citations) does not do that. I have tried restarting both Zotero and Word, and the problem persists. How can I disassociate the content from the bibliography to stop it from being deleted when the bibliography refreshes?
  • Are you using Bookmarks or Fields in Zotero Document Preferences to store citations? Either way, you should copy out the text of document out from the biliography field and paste it somewhere else. That might not work in unlinking it from the bibliography, in which case you should either use special paste (under right-click menu) or paste it in a different document editor such as libreoffice or google docs and then paste it back into word.
  • I am using Fields. I think there is some unfortunate interaction between track changes in Word and Zotero updates. Copying and pasting the problematic content into a new document causes me to lose tracked changes, but I've just decided to go with that in order to fix the Zotero bibliography problem. Thanks for your assistance.
  • Yes, using Zotero with Track Changes enabled is not recommended and might cause weird bugs or citation corruption, although what you have described is more unusual than what we've generally seen. If you're able to figure out a way to reproduce this please post here.
Sign In or Register to comment.