Lookup Failed

Over the past few days, I've tried a half dozen times to add a book to my library using Zotero's search via ISBN identifiers. Each time I get "Lookup Failed." "Zotero could not find a record for the specified identifier. Please verify the identifier and try again." This has happened with multiple ISBNs; no matter what ISBN I use the Zotero ISBN search now seems to generate this error. Three days ago every ISBN search worked well. Now, no success.

I'm running 5.0.94 on a MacBook Pro running Big Sur.

  • Can you provide a Debug ID for an attempt that fails?
  • edited January 30, 2021
    Thanks for your response. And I'm sorry to be slow about this.

    Based on what I'm seeing below Zotero uses www.lulu.com to do its ISBN lookup, and from time-to-time lulu.com seems to fail. The same ISBN returns the book info when plugged into an alternative – e.g., isbnsearch.org.

    Here's the log . . .

    (3)(+0000001): HTTP GET http://www.lulu.com/shop/search.ep?keyWords=9781453210482 succeeded with 200

    (3)(+0000001): Translate: Could not find a result using Lulu

    (3)(+0000000): No more translators to try

    [additional output removed — D.S.]
  • (Generally please post debug IDs, not log excerpts).
    Zotero queries the Library of Congress, the German consortium of academic libraries, and Worldcat (and then Lulu) for ISBNs. None of them has an entry for that ISBN, likely because it's an ebook ISBN, so lookup fails.

    The regular book ISBN 9780749386061 works fine
  • @dstillman: Is it possible the lookup is failing because the title is marked as explicit content? I'm having the same problem with ISBN lookup in Zotero for The Gulag Archipelago. I tried searching directly in Lulu and received a prompt about explicit content and asking me to verify my age.
  • @psmith6180: No, Zotero hasn't used Lulu for lookup in a while.

    We always need an example identifier for a lookup failure.
This discussion has been closed.