OpenOffice freeze when insert citation


today I worked with OpenOffice 3.1.1 (Opensuse 11.1) (Plugin 2.0a2) and Firefox 3.5 (Plugin 2.0b4, I think it was 2.0b4). My document contains many references (more than 100). After insertion of one reference, I got an error message:
"An unexpected error occured while performing this operations: File"/home/michael/.oo3/uno-packages/cache...... VALUE is out of range!"
I found out that I can insert only a defined amount of references. The problem occured independent of the choosen reference.

Now, I installed the new Firefox plugin 2.0b6.5. The result: OpenOffice freeze when clicking on adding a reference :-(.
I tried to deinstall and reinstall the OpenOffice plugin. Same result.
I tried to install the 2.0a3 OpenOffice plugin. Same result.
I tried to switch off Java in OpenOffice. Same result.

Has somebody any idea, how to reawake Zotero in OpenOffice?


  • Hi,

    today, there was the next version (2.0b7 firefox plugin). I reinstalled the new FF plugin, I deinstalled the 2.0a3 OpenOffice plugin and installed the Firefox OpenOffice plugin.

    The result was, I got following error message:
    Zotero Integration Error
    Firefox could not load the component required to communicate with your word processor. Please ensure that the appropriate Firefox extension is installed, then try again

    What got wrong?


  • Addition:

    I checked the Integration Preferences in the Firefox plugin:

    They were OK. This could not be the reason for the problem


  • I have the same issue as in the second post. After having installed zotero 2.0b7 and zotero openoffice integration 3.0a1 on my linux system, the buttons in openoffice don't seem to function anymore, eventhough the integration plugin seem to have been correctly installed in ooo (ooo's extension manager correctly shows the 3.0a1 extension). Whenever I want to add a citation in ooo, firefox shows the above error "Firefox could not load the component required to communicate with your word processor. Please ensure that the appropriate Firefox extension is installed" and starts eating 100% of the cpu and in most cases it's stays like that until I kill the firefox process...

    In my case the integration settings are (on opensuse 11.1 64bit):
    Java URE Directory: file:///usr/lib64/ooo3/basis-link/ure-link/share/java/
    soffice Executable Directory: file:///usr/lib64/ooo3/program/
  • What Java plugin do you have in Firefox on OpenSUSE?
  • I'am using following Java plugin:
    Sun Microsystems 1.6.0_0
    It's linked with /usr/lib/jvm/java-1.6.0-openjdk-1.6.0/jre



    P.S.: Along with kobbejager I have the problem that firefox needs much CPU Power (about 50%) after clicking add citation.
  • edited September 15, 2009
    about:plugins tells me that I'm using the IcedTea Java Web Browser Plugin 1.5.1, for 64bit.

    The corresponding opensuse packages installed are "java-1_6_0-openjdk" and "java-1_6_0-openjdk-plugin" (according to the discription based on openJDK and icedTea). Also installed is Sun Java 1.5.0 (but there is no 64bit plugin) and gcj.

    Finally, ooo was linked to the Sun 1.5.0 version. Just now, I changed this to the openjdk version (which corresponds to the one used by the firefox plugin), removed the ooo zotero integration extension and reinstalled it from within the firefox zotero integration add-on. Same result...

    michaelhust: do you have a 64bit or 32bit system? I guess 32bit?
  • Simon can correct me if I'm wrong, but I believe Zotero's OpenOffice plugin does not (currently) work with the IcedTea plugin and requires the Sun plugin. Though if there's no 64-bit Sun plugin, that might be a problem...
  • Hi,

    64bit can't be the problem. I'am using a 32 bit installation.
    I also tried Sun Java 1.5.0_20, here the same problem occured :-(.


  • I additionally installed now the original Sun Java 1.6.0 using the package manager.
    Then I chose Sun Java 1.6.0_15 linked with /usr/lib/jvm/java-1.6.0-sun-1.6.0/jre.

    Also with this original Sun (not Sun openjdk version) I got the same problem.


  • Did you try the Sun Firefox plugin rather than IcedTea?
  • edited September 15, 2009
    ok, it seems I was lagging behind in my information. For Sun Java 1.5 there was no 64bit plugin, but there is one for 1.6, so I upgraded this, and uninstalled the openjdk version. I verified in firefox if the plugins were correctly installed (about:plugins - no openjdk/icedtea plugin anymore, but "Java(TM) Plug-in 1.6.0_15"). In ooo I removed the zotero integration extension (extra > extensions) and I made sure that ooo used the newly installed sun java was selected (extra > options > > java). I closed ooo entirely (also the taskbar starter), restarted it and tried the add citation button, with success this time.

    So, for me, the problem is solved. I hope you can do something with this information, Michael. Best guess seems to remove the openjdk packages entirely in yast...

    Thanks for the help!
  • Hi,

    now it works :-)!
    In my Firefox the IcedTea Java plugin was installed.
    I deinstalled all Java openJDK packages using the package manager (yast2). Deinstalled all Zotero plugins and rebooted the machines.
    Afterwards, I found the original Sun Java 1.6. plugin in Firefox, chose the original Sun Java 1.6. in OpenOffice and installed both plugins. After clicking "reinstall components" in the Zotero OpenOffice Integration plugin, everything worked :-).

    Many thanks for your help!!

  • Worked for me too! Thanks very much!
  • edited September 15, 2009
    Btw, I'd add a bit more (Dan) to the installation instructions. They're not at all clear for the non-techie (or the semi-techie).

    What I needed to know was to disinstall the previous extension from within OpenOffice, and then - having checked I had the correct Java settings etc., and having added both plugins to FF - use the "preferences" button for the OO Integration plugin (in FF) to get to that all-important "reinstall components" button. Explain that this adds the new extension to OpenOffice (need to restart OOo to see it, btw).

    Worth explaining the step of "reinstalling OOo components" to users, as it's not obvious. And without explanation it's particularly mystifying to the semi-techie like myself who couldn't work out how a couple of add-ons in one application (FF) were going to help me do things in another completely separate application (OOo).

    But once again, many thanks, it all seems to be working. In fact, it appears to be working smoothly for the *first* time for me! I hope to be in a position to be a Zotero evangelist before long ... !
  • You shouldn't need to uninstall the previous extension—the installer should do it for you. We'll add some information on general installation (i.e., the integration XPI installs the OO components) and "Reinstall Components", but simply reinstalling the integration XPI after fixing the plugin issue should also do the trick.
  • Yeah. I see why you had/have the instructions as you did/do.

    One thing just to add. I've really no idea why the upgrade failed in my case. I didn't have any other Java than the Sun Java6. I upgraded the FF xpi and installed the integration xpi, and even clicked the "reinstall OOo components" button.

    I don't know why it didn't work. Even now.
    Perhaps it was as simple as needing to do all this with OOo not running, or of needing to restart OOo after all the xpi-related activities. That would be worth suggesting to users, I'd have thought. But I honestly don't know if that is what would have made the difference.

    Perhaps a set of simple instructions explaining what is going to happen in the ideal case (and including such things as the restarting of FF and OOo, both of which are involved seemingly on even the simplest and most successful of upgrades), plus a set of more careful painstaking instructions like those on this thread for installation if the simple method fails. Just a thought.

    Anyway, I do see where you're coming from on this. Thanks for all the help. Better actually do some research now .... ! Cheers.
Sign In or Register to comment.