Zotero connector downloading but not linking pdfs


I'm having some problems with Zotero connector. When I try to download a paper from an URL like:


it downloads the snapshot and the comments, but not the pdf apparently, so it doesn't show up in Zotero. The weird thing is that the pdf is actually downloaded twice and can be found in my local "storage" folder inside /my_username/Zotero. The two pdfs are placed in different "tmp_..." folders, whereas the snapshot and actual link of the paper is in the same directory but inside a different folder (with some capital letters and numbers as name). I have tried to create a report of this:

Report ID: 70456898

I hope it works, I don't know if I've made it correctly. I'm using google drive as cloud storage, in case it helps.

Thanks for your help.
  • Can you provide a Debug ID (different from a Report ID) for Zotero for a save attempt that doesn't download the PDF?
  • Yes, I've generated the following debug IDs, for Zotero and Zotero Connector:

    Zotero ID: D1817932493

    Zotero Connector ID: D1843339335

    hope it helps.
  • edited November 29, 2020
    Win error 5 during operation move on file C:\Users\[…]\Zotero\storage\tmp-Egamjt (Acceso denegado.
    Something is preventing Zotero from moving the folder with the downloaded file into place. The most likely cause of this is security software on your computer interfering with Zotero. If you're running any non-standard software, you should try disabling it temporarily to see if that fixes the problem.

    It could also potentially be due to file permissions within your Zotero data directory, though that's less likely.
  • edited November 29, 2020
    [JavaScript Error: "Win error 32 during operation remove on file C:\Users\[…]\Zotero\storage\tmp-RM5E5j\[…].pdf (El proceso no tiene acceso al archivo porque está siendo utilizado por otro proceso.
    And if there are tmp-* folders within 'storage', you should delete them. It looks like Zotero is also unable to delete the temporary folder.
  • I tried disabling my antivirus and it worked, thank you!

    I know this may be out of the forums' scope but, do you have any idea how can I give Zotero permissions so that I can use it without disabling my antivirus? I'm using AVG antivirus by the way, and after searching for a bit I haven't found anything that could work.

    Thanks again for your help.

  • Sorry, I'm afraid I don't have anything to suggest there. If you can whitelist specific programs or folders, you could try that, or you could try disabling individual features to see if you can figure out if there's a specific feature that's causing it.
Sign In or Register to comment.