Says "zotero is online" but will not save citation

Hi. I added 60+ references without a hitch a month or two ago. I today went to add two more paper citations to the list- and it won't work. I am in firefox browser, as usual. I can see the red Z to the right of the address bar. But when I mouse over it, it says"Zotero is online". If i try to click on it to save to zotero, nothing happens (nor does it say "save to zotero". )

What have I dont wrong?

I don't remember doing anything different last time. I then ran zotero.exe now to make sure i have the latest version, but no different. I checked with a non-private browser window (even though i have the controls in zotero set to be accessible within private window) and its the same thing. My window for zotero showing all my references is up as it always is. i tried closing that too, but same issue. Have tried refreshing the windows where it won't save, but same thing. I've also tried two different browser pages, but same issue on both. I checked my connector in firefox and it still shows that zotero is enabled (I did not accidentally turn that off, nor did i change any settings).

Can anyone help? Thanks.
  • If you're just seeing the red Z with "Zotero is Online" while looking at an actual webpage, something isn't right.
    When you right-click on the Red Z and select "Manage Extension" what does it say as the version number?

    Could you try disabling all other add-ons and restarting your browser for testing?

    Finally, if none of that helps, a debug ID for reloading any pages (e.g. this one) from the connector would be useful.
    Note that right-click --> Preferences might not be an option. Instead, click the three dots at the top right of the Zotero --> Manage Extension entry and select Options. Then follow the linked instructions.

  • Thanks much for reply. I will first try just restarting browser as you suggest. I have quite a number of windows open that I have needed and have not been able to shut down.
  • p.s. it says the version is 5.0.76 last updated Oct 25, 2020. That may be stale info though since yesterday i downloaded latest zotero vesion.
Sign In or Register to comment.