Zotero Integration Error in a brand new Word document

This discussion was created from comments split from: integration error in the zotero plugin (word document).
  • Hi -- I'm getting Zotero Integration Error in a brand new Word document (using latest Windows system). I dont' have track changes on, just composing the document. What's your suggestion?
  • (It's better to start new threads for new issues rather than posting to someone else's thread. I've moved this to a new thread.)

    To start, we'd want a Report ID after the error occurred.

    What exact version of Word?
  • Word 2016. No problems before, and rarely with older documents!
  • Report ID: 1492637453
  • FYI: I am now getting the same message in an older Word document that I'm editing: Report ID: 1362612634
  • What's the exact, full version of Word 2016?

    You should check to see if either Zotero or (more likely) Word is running as administrator, and if so make sure neither is:

  • Microsoft Word 2016 (16.0.5083.1000) MSO (16.0.5080. 1000) 64-bit

    No, not as admin!
  • Hi -- I figured out the pattern here. When I exited from Word, then started it again with the same document, Zotero would work fine. But when I clicked on Save File, to protect my work, Zotero would stop working and I'd get the Integration Error box: new report ID: 446282414.
  • Are you saving to OneDrive?
  • I save to my regular hard-drive, but OneDrive backup is usually synching
  • And this happens no matter where you save to? E.g., your desktop? Generally this error happens when people save to the OneDrive folder.
  • Just tried various manual "saves" -- to desktop, to file. In every case I can't use Zotero afterwards and have to exit and reload the file. Weird!
  • @adomasven may have some other ideas here.
  • @DavidTf Could you produce a Debug ID from Zotero?

    1. In the Zotero Help menu, go to Debug Output Logging and select Enable.
    2. Open a document on disk, add a citation with Zotero, then save the Word file and perform another Zotero operation that fails.
    3. Before doing anything else, return to Zotero Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • Followed your instructions: Report ID D304513617
  • edited November 25, 2020
    Could you download RotView and run it with Word? Open the document you performed the above operations for the debug log, then run RotView. You should see the document path listed in the Display Name. Save the file in Word. Press "Refresh" in Rotview. Does the path of the file change (or it has disappeared)? What is it now?
  • I may not be doing this correctly. I downloaded RotView, but the times/dates in the right column are all off. I'm not sure what this is monitoring? If I did it correctly, I didn't see any change in the file path on the left column, though, after I clicked Save.
  • You may ignore the times and dates. Did you press Refresh in Rotview? Did you try to use Zotero after the save and confirm it wasn't working? Basically we're looking to see if there's any change to the path in Rotview after the change that makes Zotero not work on a document.
  • as far as I can see, it's the same path (or location on the computer). If followed this sequence:
    - loaded Rotview
    - loaded Word document
    - refreshed Rotview and took note of file path at top of box
    - fiddled with Word document and clicked Save
    - refreshed Rotview and noted same file path

    is that correct?
  • Yes. I'll see whether I can get the Word plugin do output some more detailed debugging information about this and get back to you shortly, but in the meantime could you create a new User Account on this computer and see whether it works correctly there?
  • I can't do that -- the admin account is handled by the university tech people. I don't really have time to involve them.
  • Is this a lab computer or your personal university computer? Did you install Zotero yourself on it? Does anyone else in the university have a similar issue? It could very well be some issue with account settings, since we haven't seen anything like this before at all.
  • This is a personal university computer that I use at home. I installed Zotero myself, but normally it has worked without many glitches. I may have to try some other documents to see what the pattern is beyond what I told you.
  • You might want to try saving the document somewhere closer to your User directory, like on Desktop or in Documents and use a shorter simpler name without spaces and see whether that has any effect.
  • Hi! I'm having the same issue, Windows 10, Word 2016.
    I apparently am running both Word and Zotero with "elevated" privileges. But it's my computer, so my normal user is admin. How do I even start these apps as non-admin...? Sorry for being stupid.
  • You'd have to check this but in reverse.
  • Actually, I found that link, did the process - but looking at the file, the checkbox "Run as administrator" is not checked.
    Still, when I check the process in Task manager, it runs with "elevated" privileges.
  • Okay, so I just tried logging out of my regular account, and into a Guest account without administrative privileges - and it worked!

    However, I still need to find a way to hinder Word and Zotero from being run with elevated privileges in my normal (admin) account. Will search for a solution - if anyone already knows of one, please share.
  • Okay! So I think my problem might have been that I didn't actually actively install the Word addon, from within Zotero (because it seemed to have done it automatically).

    When I was logged into my Guest account, I did install the addon, and when I went back to my regular admin account, the Word addon was working!
    Still a bit annoying having to approve Zotero as a macro everytime I start Word, though? But it seems to be working now.
Sign In or Register to comment.