Zotero tries to check the nonexistent.prop file on the WebDaV server


I'm a network administrator and sorry that I'm not using Zotero myself. But I offer a webDAV server to my users. A user registers his bibliography with Zotero on my WebDAV server and it works. But I can notice that his zotero client makes many requests to get the file nonexistent.prop.

"GET /zotero/wrobel/zotero/nonexistent.prop HTTP/1.1" 500 -

I have verified that this file does not exist on the server.
The issue is that I have three ou four GET per second and almost 190 per minute.
It is too many verbose connections to the server.

When the user tries to test the connection to the server, he receives an error message indicating he is not authorized to access the nonexistent.prop file.

He gave me his configuration :
Zotero : 5.0.93
MacOSX Catalina, version 10.15.7

How can we fix this issue please ?
Should we have this file to the server ?

  • A nonexistent file shouldn't return a 500. You'll need to fix your server's configuration.
  • @dstillman
    Thanks for your help.
    I can't figure out why my server returns a 500 code error instead a 404 "Not found", as it is usual in this case.
    But a "apachectl configtest" return "Syntax OK"

    I tried to create this nonexistent.prop in the user directory and immediatly the requests stopped.

    "GET /zotero/wrobel/zotero/nonexistent.prop HTTP/1.1" 500 -
    "GET /zotero/wrobel/zotero/nonexistent.prop HTTP/1.1" 200 -
    "OPTIONS /zotero/wrobel/zotero/ HTTP/1.1" 200 -
    "PROPFIND /zotero/wrobel/zotero/ HTTP/1.1" 207 300
    "GET /zotero/wrobel/zotero/nonexistent.prop HTTP/1.1" 304 -
    "OPTIONS /zotero/wrobel/zotero/ HTTP/1.1" 200 -
    "PROPFIND /zotero/wrobel/zotero/ HTTP/1.1" 207 300

    I suppose that now Zotero is satisfy to have found this file and he has stopped checking.
    Tomorrow, I will ask feed back from the user.


  • The server logs should tell you more about the 500, but we obviously can't help with that.

    Creating nonexistent.prop is absolutely not the solution. The whole point of that check is to ensure that the server returns 404 for missing files, which it relies on for the normal sync process. You need to fix your server.
  • Ho ho I understand the problem.
    I will see how to fix it.
    Thank you very much
  • Yes I know what caused this 500
    It's an .htaccess which comes from Joomla. It is a security protection that prevent 404.
    I have to find a way to modify this .htaccess
  • If it can help someone, adding this exclusion in Joomla .htaccess fix the issue :

    RewriteCond %{REQUEST_URI} !/zotero
Sign In or Register to comment.