Word plugin doesn't show authors for already cited references

Hi,

I have a problem with the Zotero Word Plugin. If I want to add/edit a new citation, everything works as expected. However, references that I have already cited in the document are listed without author names.

For example, if I want to cite Smith (2000) for the first time, I press "Add/Edit Citation", the pop-up shows up, I type "Smith 2000" and the "My library" section of the list correctly shows:
Smith (2000), Journal of Alternative Facts, 50(1), 100-110

However, if I want to cite him a second time and do the same, the "Cited" section of the list only shows:
(2000), Journal of Alternative Facts, 50(1), 100-110

The name is missing. That way, I cannot tell whether this is actually the correct publication. For example, it could also be Smithson (2000).

This problem is present since I imported a Zotero library RDF file into my account.

Any help would be greatly appreciated.

Best,
Torge
  • First of all, the title should be listed above author (year) -- is that not the case?

    And then, does this happen consistently for you for all items? What version of Zotero exactly?
  • edited 9 days ago
    Hi, thanks for your reply!

    The titles are correctly displayed in all cases. The problem occurs for all previously cited items, but the same items are correctly displayed in the "My library" section. Also, I just noticed that there's no problem in new documents, only in existing ones.

    I'm using Zotero 5.0.93, Word for Microsoft 365 and the APA 7th edition citation style.
  • In your existing documents, if you change to a different style and back, does the problem persist?
  • edited 9 days ago
    Hi, I tried changing the style from APA 7th edition to APA 6th edition, American Political Science Association and Chicago Manual of Style 17th edition and back.
    Unfortunately, the problem persists with all these styles.

    It might have to do with the fact that the now affected documents were created before I exported and reimported the respective library as an RDF file. Both the export and import worked well, though.
  • If you go to the citation to the item with the cut off authors in your document and open the Edit Citation window, then click on the blue bubble for the citation, do you see a View in My Library button?
  • It might have to do with the fact that the now affected documents were created before I exported and reimported the respective library as an RDF file. Both the export and import worked well, though.
    That's not a good idea. You shouldn't use Export/Import in normal usage and it'll break the connection of your Zotero library to items in Word documents.
    Have you looked at the bibliography in those documents? It might just be that the metadata is broken and it's not using the metadata from your library.
  • @bwiernik : No, the "View in my Library" button only appears in about 5-10% of the citations. Does that mean the document it not linked to my library anymore?

    @adamsmith : The bibliography is good, also after refreshing it.

    Ok, I didn't know how the connection between Zotero and documents is stored, but assumed there is some kind of unique identifier for each entry which would be exported/imported along with the data in the native Zotero RDF format. Is that not the case?

    I exported the data because the project was finished and I needed some space (despite being a subscriber), but now I would like to revive it. Is there a better way to do this?
  • The link between the document and you library is for the specific item. When you export/reimport, that creates a new item that isn’t connected to any Word document. So, those items that don’t have the “View in My Library” button aren’t connected to your Zotero library at all—they are just showing the metadata that’s embedded in the document. If that embedded metadata is missing something, it won’t show up in the bibliography.

    At this point, I suggest you systematically go through your document and re-insert each citation, being sure to select the item from the “My Library” not the “Cited” section of the search results.

    Storage space has nothing to do with the number of items in your library. Item data always syncs for free. The only thing that takes storage space is attachment files. If you don’t need an attachment file, you can delete just that but leave the item intact. I suggest never deleting items, especially if you’ve cited these items in documents.
  • Thanks again for your response!

    Ah, that's too bad since it's a very long document, but it is what it is.

    Do you have any idea why the authors were not embedded in the documents' metadata (unlike all the other item information)?

    I'm aware it was my mistake and don't know if this is the right place for "feature requests", but I'd like to suggest that the RDF export function could warn about the fact that the items/identifiers/connections are lost upon export/reimport because technically it should be possible to have unique identifiers that an old document would recognize in a reimported library, so I expected that behavior (and might not be the only one). If the export function had warned me about that, I would not have deleted the library from my account after export. It's just an idea, but maybe such a warning could save other people's time in the future.

    Concerning storage space, I do need the old PDFs because many universities are cancelling certain journal subscriptions.
  • edited 9 days ago
    If you need to keep the attachment files, then subscribing to Zotero storage or using a WevDAV service with Zotero (there are several free services that provide substantial storage space) are your best options. You could also set up Zotfile plugin to convert your attachments to links so that they are not synced.
  • I'm a Zotero subscriber, but I'll think about using WebDAV in the future.

    Thanks again for your help!
Sign In or Register to comment.