Cannot type a name for a new collection

Hi,

I cannot create a new collection with Zotero 5.0.93 for mac because I cannot type a name in the text box. I can type in any other text boxes, so the issue is really in the creation of a new collection. My OS is Big Sur. Appreciate any help. Thank you very much.
  • Does this still happen after restarting Zotero?

    What exactly happens when you try to type in the text box? Are you saying you see "Untitled" but can't type over it? What happens if you press Return?
  • edited 11 days ago
    It happens after restarting and even after reinstalling. I tried restarting my laptop but still had the problem.

    I cannot type over "Untitled". I can create a new collection "Untitled" when pressing Return. One thing to add is that I can create a new collection and rename it on zotero.org. Thank you.
  • I can create a new collection "Untitled" when pressing Return.
    If you can do this, as a temporary measure, you should be able to double-click the Untitled collection in the left-hand pane and rename it there.

    Do right-click → Cut/Paste or Cmd-X/Cmd-V work in the popup?
  • That works! Thank you very much for your help!
  • edited 11 days ago
    That's still not a fix, though.

    What's the answer to my Cut/Paste question?

    Are you running any unusual software on this computer? I can't reproduce this in Big Sur.
  • Cut and paste works in the popup. I'm not sure about unusual software but I think it's unlikely a cause of the problem.
  • Well, again, this isn't a general problem in Big Sur, so there's something specific about your computer that's causing this to happen. You could try running Zotero from a new macOS user account to see if it still happened there.
  • edited 11 days ago
    Thanks for the further suggestion. I do not have the issue when using Zotero on a new user account. So does this mean some unusual software is running on my main user account?
  • Hard to say, but it's something about that account. You can also try a new Zotero profile to see if that makes a difference. (If not, you should delete it after to avoid confusion.)
  • I figured out the cause of the problem. It seems that the popup does not accept the input source "Japanese-Romaji". So even though I type in English, as long as it is from this input source, nothing is typed in the popup. Thanks!
Sign In or Register to comment.