Zotero links unlinking in Google Docs

Hello! I've been using the Zotero plugin in Google Docs for a year or so, and in the last few weeks citations that I've just added soon "unlink" and appear in red. A new icon appears in the upper right with a Z and broken link pictured, and when I click on it, it shows the links that have freshly unlinked. How can I prevent this from happening?
  • The only cause of this we're aware of is your or someone else with access editing the document without having the Zotero Connector installed.

    If you can reproduce this reliably, we'd want to know the exact steps to do so, ideally in a new document.

    Note that the icon would appear on the next update or refresh after the operation that caused it.
  • No one else has access to the document, according to the Google Docs share settings. So it must be a bug within Zotero?
  • Well, again, it would also happen if you edited the document without having the Zotero Connector installed (e.g., on another device).

    If you're seeing it happen in a browser where the Zotero Connector is installed and enabled and you have the Zotero menu showing up in Google Docs, it's a bug. (Whether that bug is "within Zotero" is sort of a matter of perspective — there could be a problem in Google Docs that's triggering this, but they don't have anything to do with Zotero integration.)

    Again, you'd want to make sure that it was actually happening due to some operation after a refresh where the citation was still fine and you weren't getting the warning.
  • It has happened to me as well. The two things I recall doing after everything worked fine and before it broke are:
    1) I tried (unsuccessfully) to change the citation style used by Zotero in the document to a newly added format.
    2) I copy-pasted some text from this page into the Google Doc: https://www.elsevier.com/journals/energy-research-and-social-science/2214-6296/guide-for-authors

    An additional problem arose: I would like to unlink those broken citations, but now that doesn't work either. All those citations are there in red, but "unlink citations" gives an error, so I am stuck with a document with lots of broken citations that I can't unlink. :(
Sign In or Register to comment.