830249070

Hallo,

seit gestern, immer wenn ich Zotero öffne kommt eine Fehlermeldung und das ich es neu starten soll. Meine Bibliothek wird nicht mehr angezeigt.

"Ein Fehler ist aufgetreten. Bitte starten sie Zotero neu"

Was kann ich tun?

Vielen Dank schonmal im Voraus
Christine
  • edited 10 days ago
    [JavaScript Error: "SyntaxError: invalid escape sequence" {file: "resource://zotero/loader.jsm -> resource://zotero/react-dom.js" line: 17244}]
    Can you provide a Debug ID (different from a Report ID) for Zotero startup through getting the error, using the "Restart with Logging Enabled…" option?
  • Thanks a lot for you respond.

    The Debug ID is D1032144936.

    Best regards
  • TypeError: ZoteroPane_Local.tagSelector is undefined

    TypeError: ZoteroPane_Local.tagSelector is undefined
    ZoteroPane</this.setTagScope@chrome://zotero/content/zoteroPane.js:1123:9
    ZoteroPane</this.onCollectionSelected/</<@chrome://zotero/content/zoteroPane.js:1198:9
    Zotero.LibraryTreeView.prototype.runListeners<@chrome://zotero/content/xpcom/libraryTreeView.js:79:36
    If you check your database integrity from the Advanced → Files and Folders pane of the Zotero preferences, does it pass?
  • Sorry, what do you mean when you say, "does it pass?"
  • After clicking the Check Database Integrity button, does it return a message saying “No errors were found in the database” or similar?
  • Ah, thank you! Yes it says that no errors were found
  • Could you go to Tools → Developer → Run JavaScript, paste in the following code, click Run, and let us know the result?

    var el = document.getElementById('zotero-tag-selector-container'); el.hasAttribute('collapsed') + ':' + el.getAttribute('collapsed') + ':' + ZoteroPane.tagSelector
  • Yes, it says:

    false::undefined
  • edited 11 days ago
    Do you see the tag selector in the bottom left? If so, does it help if you try to close it and reopen it, and then restart Zotero, or some variation on that?
  • No, on my desktop version I don't see the tag selector. I now deleted the program and installed it again, but it still doesn't work...
  • OK, what's the result of this?

    document.getElementById('zotero-tag-selector-container').height + ':' + typeof Zotero.TagSelector.init(document.getElementById('zotero-tag-selector'), { container: 'zotero-tag-selector-container', onSelection: ZoteroPane.updateTagFilter.bind(ZoteroPane) })
  • It says

    TypeError: Zotero.TagSelector is undefined
  • edited 10 days ago
    If you create a new Zotero profile called "Test", does it happen in that one too?

    (If not, we'll do further debugging to figure out the problem in your original profile.)
  • Thank you so much for your help.

    I created a new Zotero profile, and it's still happing.

    Sill saying "An error has occurred. Please restart Zotero."
  • Can you provide a Debug ID from the new profile, using "Restart with Logging Enabled…" again?
  • Yes it sais

    D871199350
  • edited 10 days ago
    That’s either the original profile or it didn’t properly create a new Zotero data directory like it’s supposed to when you create a new profile. Can you start up in the new profile, go to Advanced → Files and Folders in the preferences, and make sure the data directory is set to a “Zotero Test” folder in your home directory, next to the existing “Zotero” folder? You may need to create that folder if it doesn’t exist.

    Then I’d want to see another Debug ID starting up in the new profile with that data directory set.
  • Hi,

    I created a new folder because it didn't exist. Here is the new Debug ID:
    D1177592456

    thank you!
  • If you change the language in the Advanced pane of the preferences to English, does that make a difference?
  • Yes it does!!! It's working again!
  • Thank you so much!!! I have never thought of that.
  • You really saved me with this!
  • edited 10 days ago
    OK, so you can reopen the profile manager with -P and delete the test profile, and you can also delete the "Zotero test" folder in your home directory.

    Back in the original profile, if you switch it back to "Deutsch", this happens again? Unfortunately I'm not able to reproduce this with the German locale, and no one else has reported it, so it's not totally clear what's causing this…
  • I am little bit scared that when I switch it back to German language it won't work again... I will stay with the English language, that's fine with me :)
  • edited 10 days ago
    I mean it probably won't work again, but you can then switch right back to English. For troubleshooting, it's just helpful for us to confirm that switching to German reliably breaks it for you.
  • Yes, I understand. I will do it in 4 weeks okay? Then I have to hand in my master thesis. I promise I will come back to this.
Sign In or Register to comment.