No comma in APA 7th citations

This discussion was created from comments split from: Problem: Mixed citation styles in reference list.
  • I realize this isn't the correct thread, but it is kinda close. I'm a newbie, but my zotero is incorrectly putting my in-text citations as (author date) with no comma even though I'm selecting APA 7th edition. Any idea why?
  • I realize this isn't the correct thread, but it is kinda close.
    No, please create new threads for new issues.
    my zotero is incorrectly putting my in-text citations as (author date) with no comma even though I'm selecting APA 7th edition
    Most likely you're choosing ASA, not APA.
  • at what point in the process of adding a citation (either importing into zotero) or adding as an in-text citation, does zotero ask you what style you want? it seems sometimes it asks me when i'm clicking "insert citation" and sometimes it doesn't.

    i just did a test, imported a .ris citation into zotero, and the system did not ask what style i wanted. i hit "insert citation" (and used the newly imported citation) and it did not ask me the style either, and inserted it incorrectly (without comma between author and date for APA 7th. Thank you.
  • just went through some tutorials. should i be choosing my citation style via zotero>preferences>cite>style manager and select from list? well, i do that, and choose apa 7. then, when i check the document and insert a new citation, it does not include the comma. i go back to zotero>preferences>cite>style manager and apa 7th edition (nor any style) is highlighted in the list. is the citation style i've selected in style manager supposed to stay highlighted? what is the best way to choose your citation style and why would the software not do what you have selected?
  • edited 20 days ago
    should i be choosing my citation style via zotero>preferences>cite>style manager and select from list
    No. That has nothing to do with your document. That's just where you add or remove styles.

    Zotero generates APA citations correctly. It's inserting them in whatever style you chose when you started working in the document, when it first shows the Document Preferences window. You can change the style after the fact by reopening the plugin's Document Preferences window.
  • i have word that looks like this. https://www.zotero.org/support/kb/no_toolbar_in_word_2008_plugin

    i actually have word 2011, with a tiny little toolbar plus that applescript entry.

    got it! i had apa 6th selected. thank you distillman!
  • (You had ASA 6th selected, not APA 6th.)
  • I didn't know if my thread would be seen and wanted to call attention to it. Glad this is an active forum. Just delete it then. Thank you very much.
  • you're right. i just went to doc prefs (thanks to you). mis-read it. wow, do you do private consulting distillman? happy to pay! thank you so much!
  • No, but you can always post your questions here. We’re happy to help.
Sign In or Register to comment.