Synchronisation between Android tablet and computer

Hello everyone! I'm using an Onxy Boox tablet for academic reading. I can reach my archive through "Zoo for Zotero" or "ZotEZ" easily and they synchronise the information but when I open a PDF on the tablet and make annotations, these two apps cannot synchronise my highlights and notes. I would like to see my annotations from tablet on my computer and vice versa as well.

I tried ZotFile (https://www.zotero.org/support/sync#alternative_syncing_solutions).
I also made a Google Drive connection via ZotFile (I also use Autosync for Google Drive) but it didn't help. What should I do? Is there anyone who can menage to sync their tablet and Zotero on PC?
  • I have exactly the same problem! Did you resolve it?
  • Yes! Are you using an Onyx Boox device as well?
    For me, using Zoo for Zotero with ZotFile's "Send to Tablet" option has resolved it. I think ZotEZ is more problematic. I will copy paste my post from another platform:

    ZotFile plug-in enables sending and getting PDFs with their annotations from different platforms like different computers, tablet, phone etc.

    After installing ZotFile to Zotero, I created a folder in my Drive for ZotFile (it should also be synced by Autosync) and I made it my "source folder for attaching new files" in ZotFile preferences.

    I connected that folder to Zoo for Zotero as well.

    At my computer, I sent my articles to the tablet through "send to tablet" option (under right-click --> manage attachments). Now I can open Zoo for Zotero on my tablet, open a PDF with the PDF reader, make highlights, take notes.

    When I close the PDF on the tablet, Zoo asks permission to upload it. Then I go to Zotero at computer, I click the sync with Zotero button and they sync instantly.

    It looks like so much to do when it's written but after you connect ZotFile and Google Drive with Autosync, there is nothing much left.

    You can look for the details of ZotFile from this page: https://www.zotero.org/support/sync#alternative_syncing_solutions
  • I tried to figure this out today (also using an Onyx Boox). Apparently the issue is the Neo Reader. Once I moved to a different reader -- the developer seems to recommend Xodo -- I was able to use Zoo for Zotero all by itself, with perfect and easy sync. Using zotfile and google drive etc and having to "send to tablet" and "get from tablet" seemed way too involved for me (it also didn't quite work as the tablet somehow kept creating duplicates of the annotated pdfs?). I'm a bit sad that I can't use the Neoreader as it's so smooth, but I prefer knowing that my files will be easily synced and available in my zotero library.
  • Did you check NeoReader's export settings in Settings -> Export settings (including "Export to Storage\note" and "Export to the same directory as the source file"). For mine, the first, storage one, is checked and the second isn't. Maybe that's why mine doesn't produce any duplicates for annotation. Xodo is nice but scribbling and writing is delayed like many other apps, so it's far from ideal I think.

    Also, I didn't need to use "get from tablet", I just click the refresh button at Zotero and it works. But I understand that it might be too much of a workload sometimes.
    I hope you can find the perfect way for you!
  • @aise. thanks for the cue! I was hoping to find a simpler way to make it :(

    @cruwell I tried with Xodo, but the annotation is not staying in the pdf in Zotero... What's wrong with what I'm doing??
  • @aise. Oh, ok! The same thing is ticked for me in NeoReader's export settings. Can I ask where your attachment location is in Zoo? I only seem to be able to choose folders in the downloads folder for this. I am really confused why this solution works for you but doesn't for me -- I tried all the same steps and it only worked if I also used the "get from tablet" option, without ever using Zoo & without the advantages of having a Zotero library on my boox :(
  • @cruwell Of course, my attachment location is custom path, sync method is Zotero Account Sync and "Offer to upload attachment" is on. But I couldn't see the chosen folder, I don't know why. I'm sure that I chose the same folder for I had chosen for ZotFile.

    It is really weird that it didn't work, have you checked the same thing for ZotEZ? I mean that app didn't work for me but it may work for you.

    @sojal2 I know it seems long but it is just four steps and when you complete them, you just use "send to tablet" and refresh.

  • @cruwell Also, are you sure that Autosync for Drive (or Dropbox) works smoothly? You should buy the paid version to sync files larger than 10 MB, if I remember correctly. This might be the problem as well.

    Another thing, it isn't related but I recommend that you turn off "Whiten Apps Background" option at all apps' optimization settings because it makes many options and settings "invisible".
  • @aise. I have also a Boox! About your attachment location, you wrote that you choose custom path. My problem is that no matter which folder I choose it always send me this after going back to my library:

    "Permission error: There was an error accessing your Zotero attachment location. Please reconfigure in settings"

    I look in the permission for Zoo app and it have all access... I'm in a dead end here... So I had to keep the attachment location to external cache.

    In fact, when I open in Zoo my annotated pdf with NeoReader, I see the annotations but not on my Zotero on Mac. It's like a one way because when I had stuff to my Zotero on Mac, the app on boox is fine to see the changes but not in the opposite way....

    Neoreader was set on "Export to the same directory as the source file" and after your message I change it to "Export to Storage\note" and it doesn't change anything
  • @sojal2 I think your problem derives from the error, you checked the correct place for permission, right? It's under Settings (Onyx's general settings) -> Applications -> Application info -> Zoo for Zotero -> Permissions -> click on Storage and give permission.

    You can do the same thing for ZotEZ, maybe that one will work who knows. Also, Google Play should be enabled.

    But I checked my permission settings and I realized the storage was denied for Zoo, I don't know why :/ If allowing doesn't work, maybe you can try to deny it.

    It's very basic and I'm sure you already thought but you can update them if there is any available updates (for Onyx, Zoo, and ZotEZ). Deleting caches and the app might be a solution too.
Sign In or Register to comment.