Modified citations prompt

edited October 23, 2020
This discussion was created from comments split from: Zotero keeps modifying citations.
  • I get the same message, about old citations I haven't modified when I add a new citation. I choose, "No," to "Do you want to keep your modifications and prevent future updates," since I didn't modify. After one to three of these messages they stop.
    I'm using Mac OS 10.10.5 Yosemite and Word 2011. Is their antiquity causing problems? I sure didn't want to upgrade to Mac's Catastrolina.
    I do use Zotero classic view, as I prefer seeing the whole lists of my citations.
    I have been using the stand-alone rather than the plug-in version of Zotero.

    Otherwise, superb software. Immensely time saving!

    Thanks, ~Philip
  • edited October 23, 2020
    What differences does it show between the old and new citations in the prompts?
    I'm using Mac OS 10.10.5 Yosemite and Word 2011. Is their antiquity causing problems?
    Make sure you're using the latest version of Word 2011 (14.7.7) and the latest version of Zotero (5.0.92).
  • Oh, and while it's unlikely to be relevant here, we only support macOS 10.11 or later. All Macs that can run 10.10 can be updated to at least 10.11.
  • Thanks Distillman,

    I looked each time, but couldn't see any differences between the old and new citations in the prompts. They all looked identical. If it happens again I'll double check. Mystery.
  • I've had the "You have modified this citation..." message pop up five times in about 8 uses of a simple "add citation" and "page numbers" since yesterday. I dig 'grabs' of three messages. Two showed identical "Original" and "Modified" citations. The third showed two entirely different citations, neither related to my attempted citation. I clicked "Yes," because I didn't want my attempted citation to be modified. (I usually click "No." An error popped up, "Zotero experienced an error updating your document. Would you like to view troubleshooting instructions?" That's probably a safety net, making no changes? I checked, and the two citations, "Original" and "Modified," hadn't been modified and still referenced the correct paragraphs. My attempted citation didn't happen. I tried again and it worked perfectly. Wow.

    Whatever this is, it doesn't seem to be doing any damage, so far. But.
  • Yeah, that doesn't sound right at all. That's Word, or which word processor? And anything unusual about the document? Lots of comments or track changes, changing formatting?
  • Word 2011, OSX 10.10.5 Yosemite. Mac Pro 2010. 32GB. 1TB SSD.
    The documents have some illustrations plugged in, otherwise just docx. Page view.
    I generally have a lot of windows open.
    No comments, no track changes.

    Formatting changes? Good guess. Probably found the problem:

    In my 78 endnotes, the last two I got messages about, which had the completely unrelated citations: The "Modified" citation is now in Helvetica Neue instead of Times New Roman. And maybe because I checked, "Yes," I don't seem to be able to change that.

    I take it I may have to simply delete and reinsert those citations, and Zotero will make their font consistent with the rest? Or?

    It's possible that many months ago I may have pasted a paragraph with a citation from a document in a different style. That isn't good?

  • @amphioxus: Please post further comments in this thread, where we've moved this discussion (and where you already responded once), not the one you posted to originally. I've moved your additional comments here.

    The Word plugin shouldn't care about formatting — you can change the font, bold, etc., without triggering the modified-citations prompt, and I just tested that in Word 2016. The Word 2011 plugin is older — as is Word 2011, obviously — and might have had different limitations. @adomasven might know, but you can also test this with sample citations in a new document.

    What version of Word 2011 do you have?
  • Thanks dstillman,

    Word for Mac 2011
    Version 14.7.7
    Latest installed update: 14.7.7

  • Good news: I did change the two mis-styled citations into Times New Roman. It hadn't worked when highlighted via "Format Style" and "Apply," which usually covers a whole document. Simple highlighting and using the toolbar worked.

    That probably fixes things. Hu nose. Time will. Thanks for the "formatting" hint.
Sign In or Register to comment.