Acta Zoologica Academiae Scientarium Hungaricae style bug

Recently, we found a strange bug in AZASH style. The problem is that it puts the surname prefix after the given names if I use Mendeley.

How I filled the Author list at the program:
Crommentuijn, Trudie
Doodeman, Connie J. A. M.
Doornekamp, Anja
van Gestel, Cornelis A. M.

So it is visible that in case of the last name I put the prefix before the surename and with Ecotoxicology and Environmental Safety style it looks like this:
Crommentuijn, T., Doodeman, C.J.A.M., Doornekamp, A., van Gestel, C.A.M., 1997
(Visible that the prefix is at place: van Gestel)

With AZASH style it looks like this:
Crommentuijn, T., Doodeman, C. J. A. M., Doornekamp, A. & Gestel, C. A. M. van (1997)
Here the prefix is after given names at the end C. A. M. van

My question is that is it possible to update the style to solve this problem? Thank you very much in advance.
  • Although I'm new to zotero, I think it is just a matter of info.

    For that, you just have to change the authors info of that item. I think it is already sett as default to enter the name as [Surname], [First name]. If it is that easy, you can change "Gestel, C. A. M. van" into van Gestel, C. A. M.". Otherwise you can click on the rectangle after the entry field, to change it to that format.

    But I really don't know if that sticks like that when you're referencing...
  • No, this is a style setting (demote-non-dropping-particle if you're interested in the technical details, see )

    @szabo.borbala001 -- how do you know "van Gestel" is correct in that style? Both versions exist in styles. Author guidelines, editor feedback, or published papers would all work.
  • @adamsmith Thanks for the answer! I know that is the right form, because he is dutch and prefix is part of his surename. Also, the Editor-in-Chief told me why I did not use the proper form of the author's name when he always use it in form of "van Gestel". That is when it turned out that the style did not formatted it in a way how I am intented.
  • Thanks -- this should now be fixed
  • @adamsmith Thank you very much for your help!
Sign In or Register to comment.