Index status unknown

Since updated with Version 5.0.91, Zotero tags newly added PDF index status with "Unknown". If you re-index an old one, the status also changes from "Yes" to "Unknown". For users who add new PDF from many different computers, this is an inconvenience. Are you aware of this problem? Is there a way of fixing it? Thank you very much in advance.
  • Related: https://forums.zotero.org/discussion/85642/pdf-index-unknown#latest
    and (I think): https://forums.zotero.org/discussion/comment/366554#Comment_366554

    I'm seeing the same thing: All PDFs imported since 5.0.91 are labelled unknown. PDFs from before October 9 (i.e. 5.0.90 and earlier) are shown as Yes.

    D1540951267 is a debug for an attempt to manually re-index an item. You'll see the same Error 99 for pdfinfo.exe in the 2nd link above.

    As reported in the 1st link, the actual indexing works fine.

    File permissions look right with RX on the file for all applications:
    C:\Program Files (x86)\Zotero>icacls pdfinfo.exe
    pdfinfo.exe NT AUTHORITY\SYSTEM:(I)(F)
    BUILTIN\Administrators:(I)(F)
    BUILTIN\Users:(I)(RX)
    APPLICATION PACKAGE AUTHORITY\ALL APPLICATION PACKAGES:(I)(RX)
    APPLICATION PACKAGE AUTHORITY\ALL RESTRICTED APPLICATION PACKAGES:(I)(RX)
  • What I found since my last post: PDF tagged as “unknown [if indexed]” are, in fact, indexed. Their contents are searchable and their txt versions are correctly put in the Zotero storage folder (in one of those many subfolders named with letters like “23KQW7SW” and so on). So, pdftotext-Win32 is working well. Perhaps this information may be useful.
  • Fixed in 5.0.92, available now — thanks for reporting.
Sign In or Register to comment.