Citations not active after copying between Google Docs documents

This discussion was created from comments split from: adding citations the numbering restarts at 1.
  • I'm having a similar issue as Emily. I'm currently using Zotero in Google Docs. I was working on an outline in one Google Doc and copied the references over from the outline into another Google Doc (my first draft). However, whenever I try to add a new reference, like [44] using the Zotero --> Add/edit citation feature the numbering starts from [1] instead of [44]. How do I fix this issue? I have automatic citation updates enabled. Thank you.
  • (Better to start a new thread unless your issue is exactly the same. The other thread wasn't even about Google Docs. I've moved this to a new thread.)

    Are the citations still active in the original document? That is, if you add a new citation there, does it start at 44?

    In the new document, if you click on an existing citation, do you see a popup with "Edit with Zotero" in it?

    As long as you have the Zotero Connector enabled (which it is if you have the Zotero options in Google Docs), you should be able to copy active citations between Google Docs documents.
  • When I try to add a new citation to the original document, instead of adding [44] to the new bullet, it renumbered another citation and tried to change [22] to [44].

    Yes, I do see a popup with "Edit with Zotero" for existing citations in the new document. Interestingly enough, this is only the case for citations that Zotero has auto-higlighted in a red color font. Other citations that are in a black font color don't have the "Edit with Zotero" option.
  • edited 12 days ago
    If the citations are red or black without an "Edit with Zotero" option, they've been unlinked and won't function as active Zotero citations. The most common cause of that — and the only current cause we're aware of — is copying from one Google Doc to the other without the Zotero Connector being installed. (That could be either you or someone else with access to the document.)

    Check to make sure that the citations are active and working in the original document — i.e., that you can click on them, see Edit with Zotero, and get the red bar if you try to edit them. If not, something happened to them and you'll need to reinsert them. If they're still active, try copying to a new document again. If the same thing happens, we'd want to see Debug IDs from the Zotero Connector and Zotero for copying between documents and having them become unlinked.
  • I'm pretty sure that the links are still active in the original Google Doc, so I tried copying the bibliography from the old Google Doc over the new Google Doc. However, when I try to use the Zotero --> Add/edit citation feature in the new Google doc to insert a citation from my first source, it renumbers reference [1] as [4] and then all of the references in the bibliography turn from black font to red font. I have the Zotero connector downloaded as a Chrome extension.
  • Maybe the issue is that I'm trying to use a bibliography with a complete list of citations, some of which haven't been referenced in the paper yet?
  • Wait, are you trying to copy citations or are you trying to copy a bibliography?

    Don't try to copy a bibliography. A Zotero bibliography is just a representation of the active Zotero citations in the current document. That's not something you need to copy at all, and if you copy a bibliography on its own without citations, it will turn red. (We may be able to show a clearer error message there.)

    Just copy your text with citations and insert a new bibliography in the new document.
  • I think that was my issue! I was trying to copy a the bibliography without the body of text that the bibliography was referencing. I think that the issue is fixed now, but I will comment on this thread if I have future issues. Thank you for your help!
Sign In or Register to comment.