Journal requires author's names to be capitalised


I am writing an article for a French journal named "La main de Thot", and it requires in-text citations to be (NAME, date, page number).

This looks to me like it would work with Chicago... except that the author's name has to be in capital letters.

Likewise in the bibliography, it has to be NAME, forename, date, title, place, publisher... again with the author's name in capital letters.

Could you please tell me if there is any style that does that?

If there isn't, how can I create my own style or edit an existing one (Chicago?) so that I don't have to retype all the names in my bibliography... and risk making mistakes in the process :-/

Thank you for your help !
  • If you look through the French note styles ( ) a lot of them use small caps for authors -- would that work? (It's not technically all caps, but it's a much better idea...)

    See for style editing and for style requests
  • Thank you very much,

    It says "majuscules" and they show an example with big caps, so I doubt THEY would accept small caps, although I agree with you that it's a much better idea.

    If there is no existing style, I will try to follow the style editing link you have sent me. I don't know anything about coding, but I will try.

    I could try a request too. Does it take long?
  • Dear adamsmith,

    Since your last message, I have spent a LOT of time teaching myself how to use CSL, and I finally managed to change the style to exactly what I wanted: not only "uppercase" family names, but also replacing ". " with ", "...

    This is the type of citation the magazine wants:

    (KRESS 2010)

    KRESS, Gunther R., 2010, Multimodality: A Social Semiotic Approach to Contemporary Communication, London ; New York, Routledge.

    This is exactly what the Zotero style editor gives me, and I was about to cry "victory" at LAST, but

    1) I tried to validate it through, and since it was down, tried one of the alternative validators,, as was indicated.

    It gave me the following messages:

    Error: Element name-part from namespace not allowed as child of element names from namespace in this context. (Suppressing further errors from this subtree.)

    From line 121, column 9; to line 121, column 56


    Error: Element name-part from namespace not allowed as child of element names from namespace in this context. (Suppressing further errors from this subtree.)

    From line 137, column 7; to line 137, column 54


    2) Although I can select any reference from Zotero library and use the style preview with my newly created csl style "La main de Toth", when I apply it to my article on Microsoft word, it only puts the family name in capital letters in the in-text citations, but not in the bibliography.

    Could you please tell me what I have done wrong so I can correct it?
  • Maybe I should mention that I started from Chicago author-date, as it was the closest to what I needed
  • Could you copy the style to or, save and post the URL here, please? No way to say without looking at it. (FWIW, I'm not aware of any outage at and it does tend to give more informative error messages)
  • Here is the link to pastebin.

    I have edited it a little bit, but only the "info" part, trying to do something clean (entered "template" for Chicago, included the ISSN of the journal...)

    I have just tried it again in, and got the same result.

    Concerning the validator being out, the message I got (today, as I did yesterday) :

    "Validation is taking longer than expected! (more than 6 seconds)
    This typically happens if the Nu HTML Checker website is down, but maybe you get lucky if you wait a little longer."

    (I did wait a little longer: the page has been open since yesterday, and it hasn't moved.)

    I also want to add that, as you can see in the bibliography item above, the journal wants ", " all along instead of ". "
    I have changed it, but now realise that maybe I should have just deleted all the lines that specify ", ", because I have read that lists of elements default to ", " anyway. It doesn't matter, but maybe it would be cleaner.

    Given the time I have spent on it now (and still reading on it), I'm thinking it would be good if my work could be used by other users.

    I hope this can be solved, because I have to hand in the final paper in two days (which is why I didn't do a request, not knowing how long it would take).

    Thank you for your help !
  • Validation goes right through for me -- are you using the text field?

    In any case, name-parts needs to be a child element of name, not of names, so

    <name and="text" name-as-sort-order="first" sort-separator=", " delimiter=", " delimiter-precedes-last="always">
    <name-part name="family" text-case="uppercase"/>

    That's line 99-100; same logic applies to 115-116
  • Sorry, I was not using the text field, which explains why it was not working...

    Thank you very much ! It does validate now !

    However, when I apply it to my article in Microsoft Word, only the in-text citations are in UPPERCASE, but none of the family names in the bibliography. I really don't understand, because I applied "uppercase" to both the "contributors" and "contributors-short" elements.

    Here is what it looks like with the correction:
  • Works for me. Test in Zotero using Tools --> Style editor (which would also allow you to see that you have the right version of the style installed)
  • (BTW, I'd recommend not putting spaces into the id -- it shouldn't matter, but might break someting)
  • I must be doing something wrong somewhere.

    When I try to import the CSL in Zotero, it says:

    "/Users/jean-charlesmeunier/Desktop/La main de Thot-author-date.csl" is not a valid CSL 1.0.1 style file, and may not work properly with Zotero.

    Are you sure you want to continue?

    I'm not sure why it does that. When I click OK, it works find in the style editor, but doesn't work with words.

    Concerning the id, I've deleted the space and written La-main-de-Thôt-author-date
    Is it better ? Or would you recommend LamaindeThôtauthordate?
  • Well, now that. I have modified the id to delete the spaces, the style editor tells me

    Error parsing style:
    Error: File is not valid XML

    Here is is again:
  • now that* I have modified... Sorry
  • Works for me. We typically don't put non-ascii characters into the ID, so I'd replace ô with o, but shouldn't really matter.

    Also, to test, I'd recommend installing the style in Zotero and then selecting it in the style editor. That way you can also make sure you have the right version installed.
  • Yes, I was wondering about the "ô". I have changed it.

    Now the id reads:

    so I have also changed this line to match it:

    I have restarted Zotero, tried to reinstall it. Now I don't get the message "/Users/jean-charlesmeunier/Desktop/La main de Thot-author-date.csl" is not a valid CSL 1.0.1 style file, and may not work properly with Zotero

    However, after installing it, when I open the style editor, it displays nothing, and when I click on "refresh", all I get is:

    Error parsing style:
    Error: File is not valid XML

    I really don't see what I can change. I've just tried to validate again, and it works.
  • Sorry, it is working now in the editor. I will test it in Word.
  • OK, so it shows perfectly in the editor, with the names in uppercase AND the right punctuation

    ... but in Word, neither of the two applies.

    Here is one example from my bibliography in the article:

    Low, Peter Alan. Translating Song. Epub file, Routledge, Taylor & Francis Group, 2017.

    In the Zotero editor, the same reference reads:

    LOW, Peter Alan, 2017, Translating Song, Epub file, Translation Practices Explained, London ; New York, Routledge, Taylor & Francis Group.

    Could it be that, for some reason, Word is not communicating with Zotero? It sure looks like it.
  • I just ran a test on my document. Changed it to MLA and refreshed. It works.

    Then changed it back to La main de Thôt and refreshed again. It did change it back, but to something that looks like Chicago, not taking the modifications, as I mentioned in the preceding message.

    So it seems that Word is recognising the style as a style, but I really don't understand why it is not applying the same thing as what appears in the Zotero editor. I really don't have a clue.
  • edited October 26, 2020
    Can you test in a new document? And you're testing in the style editor using the installed style from the dropdown, yes?

    Edit: and make sure there are not multiple versions, since Zotero would install multiple versions if they have different IDs
  • That was a great idea ! Thank you so much.

    I just created a document, cited 3 references, and got a bibliography, so it works.

    The only problem is that it doesn't work on the precise document where I need it, so now I need to understand why. It probably has to do with Word, because I see that, at the top of my window, the document is open in [Compatibility Mode]. Not sure why that is and what it means.

    I will do some research to find out. I suppose it must be the reason why it is not applying my changes to the bibliography.

    Anyway, thank you so much for your cooperation. I have been using Zotero for about 3 years now, learning little by little, and telling all my colleagues about it, offering to teach them to use it too... but this is the first time I tamper with the source code, and I'm very happy to have managed this with your help, really, especially since I knew close to nothing about coding a few days ago. Were I not alone tonight, I would probably open a bottle of champagne xD

    I hope that my contribution will be used by other authors. I will send a message to the journal to tell them the csl exists, in case they might be interested in telling their contributors. However, I don't know how good it is. As I said, concerning the punctuation, I'm sure there was a better way to do it... and also, it's a French journal, so normally they want french quotation marks too. I suppose they won't ask ME to change mine, since I'm writing my article in English.

    Have a very nice day !
  • Compatibility Mode uses an older Word format -- that really shouldn't matter. Try splitting the document in two for testing, and see if the bibliography inserts correctly in half of it. Also might be worthwhile testing to delete and re-insert the bibliography (in a copy of the document, just to be sure)
  • Thank you.

    I simply copied/pasted the whole article into a new Word doc, then did as you said, deleted each part of my biblio (web, discography...) and reinserted them back at the right place. I think it is now perfect.

    I did not know that it would sort it in YEARa, YEARb...

    Not sure what the journal wants, in terms of sorting, so I will see if it suits them. If not, I will just have to put my nose back into the csl. I have to say that I am beginning to enjoy it ;-)
Sign In or Register to comment.