Error report: 1766825078

Zotero standalone throws an error when I try to drag a pdf or other attachment OUT onto the desktop (or elsewhere):
"Error Copying File or Folder
Unspecified error"
I ran the error report above but it said no errors had occurred.

Steps to reproduce:
Open Zotero standalone
Choose an entry with one or more attachments
Drag an attachment out of the Zotero window onto the desktop
The file does not arrive and the error above appears in a dialogue box

Steps to attempt remedy:
Tried different attachments
Tried different file destinations (Explorer windows)
Tried re-starting Zotero
Tried re-starting computer

When did this appear? Several weeks ago. I've been checking for updates thinking it may be fixed, but it has become annoying enough to report now.

My system: MS Studio 2, Win10, Zotero 5.0.89
  • Can you provide a Debug ID (different from a Report ID) for an attempt that fails?
  • edited September 16, 2020
    I can create a Debug Output.txt file but no ID number is included. It says "Submitted with Debug ID *" (where * stands for a little clipboard character ithat seems to prevent me posting this message). But no number is stored in my clipboard and no dialogue box pops up. I can paste the rest of the file here if that's safe to do.
  • That's odd. Can you take a screenshot of that and send that along with a text file of the output to, with a link to this thread?
  • Done! Thanks for looking into everything - I begin to feel something may be wrong with my Zotero instance...
  • Not sure what's going on, but there's no debug output in that window. Do you see not see anything logged in there while you're using Zotero?
  • That was my mistake with the output, so I have re-sent it. The ID still does not show even when the logging is working.

    Anyway, back to the original issue. I have tried to work out what else is going on.
    If I right-click a pdf in Zotero standalone and click Show File, it will say "The attached file could not be found...." BUT if I instead double-click to open that pdf, it will open the file (without any errors) and display it. Afterwards, THAT file will Show File and/or drag to the desktop properly. My local file storage therefore seems to be semi-messed up - Zotero is pretending not to know where the file is but actually does!
  • Oh, it sounds like you're just trying to drag a file that hasn't yet been downloaded to your computer.

    Zotero file syncing can be set to download files "at sync time" or "as needed" in the Sync pane of the preferences. If set to the latter, files aren't download until you try to open them in Zotero, but that won't currently happen automatically for Show File or for dragging to the filesystem. We should be able to fix that for the former, but the latter might not be possible for technical reasons (though we could probably show a clearer error message).

    For now, if you want to drag a file to the filesystem, you should open it once from Zotero first so that the file exists locally. You can enable the Attachments column to see whether a file exists locally (empty or filled circle).

    Future versions of Zotero will provide more control over downloaded files, including probably the ability to download files without opening them and specify how much disk space is used for locally saved files.
  • I see. Thank you. I must have not migrated properly to my current machine and now I have continued for too long waiting for the "problem" to resolve to go back to my database as it was before. I've just changed to "at sync time" but so far nothing has changed - sync takes seconds not the expected hours to repair the database. If everything needs to be re-activated manually that's a disaster. What can I do to force "sync all"?
    And yes, I agree, that error box was indeed spectacularly unhelpful! :)
  • Nothing needs to be "repaired" or "re-activated". Your database is fine, and if you've been syncing there wouldn't be a problem switching to a data directory transferred properly from older computer — Zotero would just pull down the changes you've since uploaded on this computer.

    But if files aren't present locally after setting it to "at sync time", see Files Not Syncing.
Sign In or Register to comment.