I can't find my zotero files - HELP!

Hi. I have used Zotero to store references for my dissertation work for 4 years. A little while ago my computer shut down unexpectedly. When it opened back up I got a message that said something like you are trying to sync into an empty account. Or something like that. I can only seem to get an online version of my files. Can someone please help me with this problem?
Christy
«1
  • Thank you dstillman. I can't figure it out from that link. Do you have any other suggestions?
  • We can't help you unless you follow the steps to the end.
  • I found the files in the storage folder on Zotero. They look current. The most recent was from 8/28/20. I only see ~1MB of zotero.sqlite files. I tried to link to the "restore a zotero.sqlite file from a backup 2 minutes ago, but the link didn't work. I will try again. Thanks for corresponding with me on this problem. What else do you need to know from my end?
  • I tried to link to the "restore a zotero.sqlite file from a backup 2 minutes ago, but the link didn't work.
    I've fixed that link — it's just to a section further up the page — but that's only relevant if you can actually find a larger zotero.sqlite file containing your data. If that's not the case, don't do anything.

    You didn't provide all the information requested in that section:

    - What are "the names, sizes, and dates of the zotero.sqlite* files in your current data directory"?

    - For the 'storage' directory, it's not about it being "current" — it's about whether there are folders corresponding to your entire previous usage of Zotero on this computer. The goal is to determine if this is actually the data directory you were previously using.

    - Whether your current data directory is in the default location (“Zotero” in your home folder)
  • zotero.sqlite 983 KB, today, 9/8/20 at 1015pm
    zotero.sqlite-journal 91KB, today, 9/8/20 at 1015pm
    Data directory location: Default (/users/chjrn77/Zotero)

    Is that the additional information that you needed?
  • the next instructions appear to be that I am supposed to close Zotero. So I closed Zotero and quit the application. I did not understand what move one level up in the filesystem means. I understood the command that I was supposed to use for the macOS, but I wasn't sure where I was supposed to input the command. Thanks.
  • And 'storage'? Do you only see a few recent folders, or do you see a folder for every attachment you've saved on this computer, with dates going back as long as you've used Zotero on this computer?

    You appear to be missing all the various database backup files (zotero.sqlite*.bak) that Zotero makes in the data directory. That could happen if this wasn't actually the data directory you were using previously, but then there wouldn't be folders in 'storage' either. If there are folders in 'storage' corresponding with your previous usage, then somehow all the database files in this folder were wiped out while 'storage' wasn't touched.

    Are you running any non-standard security/cleaning software on this computer?
  • the next instructions appear to be that I am supposed to close Zotero
    As I said, unless you have a larger copy of zotero.sqlite as a backup, you shouldn't be following the restore instructions at all.
  • Yes, I am running some non standard security software called Malwarebytes.
  • It's possible that Malwarebytes erroneously deleted or quarantined all your Zotero database files, then. You can check whether it stores such files in some special location.
  • I see folders from 2017 to 2020. That may have been when I started using Zotero - 2017, but I am not sure.
  • OK, this is almost certainly the same directory you were using, then. So something deleted your Zotero database files.
  • How do I check if Malwarebytes did that?
  • edited 20 days ago
    We can't help with that — you'd have to ask them if that's a possibility. One way or another, you'd need to find a backup of zotero.sqlite that was larger than 1 MB or 5 MB somewhere on your computer, or in a backup you've made of your computer (e.g., with Time Machine).

    But it also looks like you've been using Zotero syncing, so you can also just sync to pull down all the data in your online library, at least up through whenever you last synced.
  • I do backups on my computer multiple times per day with Time Machine and with an external g-drive. I have no idea of how to find a zotero.sqlite file that was larger than you stated.
    Should I first try to sync?
    Thanks
  • There's no harm in syncing, but if you have a Time Machine backup you might as well use that — that's what it's for. Just open that same directory in your Time Machine backup and go back in the history until you see a zotero.sqlite file that's larger than the ~983 KB. Then restore that file back to your Zotero data directory so that it's named zotero.sqlite. When you restart Zotero, your data should be there.
  • Should I completed quit Zotero before opening the directory in the time machine backup? And which directory are you talking about? I want to make sure I do everything correctly so I can fix this problem tonight. Thanks
  • Yes, you should close Zotero first.

    This is all about the Zotero data directory. Zotero reads the zotero.sqlite file from there when it starts up. If you copy a backup of zotero.sqlite that contains your data into that directory and then start Zotero, it will read the data and show you your library.
  • Let me make sure I have this right:
    1) I need to go into a recent time machine backup
    2) I need to find the application for Zotero
    3) I need to open Zotero to find a zotero.sqlite file
    I just tried that and it didn't work.
    If that is not where I find the zotero.sqlite file, can you tell me how I find it in time machine? Thanks
  • No. None of that is right.

    Again, Zotero just reads zotero.sqlite from the data directory. Right now you have a new, 983 KB zotero.sqlite file with no data in it. You need to go into that exact same folder in your backup and go back in the history — that's the point of Time Machine — to find an earlier version from before all the files were deleted, and then restore that file to the exact same place in your current data directory, replacing the 983 KB zotero.sqlite file with the larger one from the backup. When you then start Zotero normally, it will show you your data.
  • When I select time machine I get this:

    Version: 2020-09-08-184142
    Choice 1: Macintosh HD
    Choice 2: Macintosh HD - Data
    Choice 3: Recovery
    Which of the choices do I click on? I tried to click on #2, then go to applications, then go to Zotero. I get this message: "you can't open the application Zotero because it is in a Time Machine backup."
    I tried to do a search in the search bar in time machine for "zotero.sqlite" and I don't find anything. I know that I have used Zotero in the past few days.
  • edited 20 days ago
    That's not how you use Time Machine. We really can't help with this — this has nothing to do with Zotero, and you can find plenty of documentation about how to use Time Machine online — but you open the Time Machine interface from Spotlight or from the icon in your menu bar. You don't browse to the backup drive manually in Finder.

    And again, in no way should you be trying to open the Zotero application in your backup. I didn't say anything about doing that. All you need to do is browse via the Time Machine interface to the exact same folder we've been talking about — your Zotero data directory — in the exact same location in your Time Machine backup and restore the file from there.

    We're well past the point where this is really related to Zotero at all, and we can't provide general computer support here, so I'd suggest you ask someone you know to help you restore a file from a backup — any technical person familiar with Macs can help with that via screen sharing — or just use Zotero syncing to pull down your latest synced data as it exists in your online library.
  • Yes, I figured out how to use Time Machine by looking online.
    I will get help elsewhere.
  • To be clear, we're happy to help with issues related to Zotero here. We just can't provide general computer support.
  • I understand that. But this is not an optimal way to receive tech support.
    I have worked with Apple, my school IT and many other software and hardware specialists and have never had this much difficulty with getting the assistance/getting my questions answered in a way that meets my needs.
    I do not find this "discussion group" format helpful in providing answers and solutions to challenging technical questions about 4+ years of work that is extremely valuable to me; work that I am concerned about losing. I have never done tech support for this type of involved problem in this manner. It needs to be done via phone or some type of video chat like Zoom or webex.
  • We help thousands of people here a year with Zotero, very successfully, and we provide more knowledgeable, in-depth support than you'll get with nearly any other piece of software. I'm a Zotero developer, and I wrote much of the code in question.

    The point here is simply that the only part of this specific to Zotero is telling you that you need to restore a pre-deletion backup of zotero.sqlite from the Zotero data directory in Time Machine to your active data directory. That's it. But you can't expect us to walk you through how to use the particular backup system you choose to use on your own computer. It's your backup system, and for it to serve any purpose at all you need to know how to use it. That has absolutely nothing to do with Zotero. You're just restoring a specific file from your backup.

    If you don't know how to use Time Machine, and your online Zotero library is up to date, you can literally just click the Sync button and be done with it. You could've done that hours ago and had your data as of the last time you synced.
  • edited 20 days ago
    And remember, the only reason you're having trouble here is that some other software on your computer deleted your Zotero databases. That's obviously not something we can do anything about. All we can tell you is that if you restore a copy of zotero.sqlite from before the deletion, you'll have your data back. If you don't know how to do that, then just sync.
  • To be clear, the only reason I suggested using Time Machine is that you said you use it. I assumed you knew how to restore from it if you were relying on it for backups. Otherwise I would've just said to sync. Zotero syncing is designed to just work with a single click.

    The only reason you might want to restore from a backup instead is if you haven't been syncing and your online library isn't fully up to date, which you can check yourself from this site.
  • I use Time Machine to backup my Mac. I set it to do this on a regular basis three months ago and that is all I have ever needed it to do. I worked with a Apple service representative to start this process. I have never had to restore files from Time Machine or any other backup disk in my lifetime of using computers.

    What is not clear to me about syncing is this: if I sync and my online library isn't fully up to date, then what happens?
    And how do I check to see if the online library is fully up to date on this site?
Sign In or Register to comment.