Location for pdftoppm on Linux Zotero installation

Trying to OCR and getting the error:

No /app/share/zotero/pdftoppm executable found.
  • pdftoppm isn't included with Zotero. If you're referring to https://github.com/UB-Mannheim/zotero-ocr, you need to actually install the executable, as noted there.
  • According to the readme, and the error being thrown, it is required.

    ## Prerequisites

    - Tesseract OCR is installed
    - for Windows see https://github.com/UB-Mannheim/tesseract/wiki
    - for Linux, Mac see https://github.com/tesseract-ocr/tesseract/wiki
    - `pdftoppm` from poppler library is downloaded and copied to the other scripts in the Zotero directory


    ## Installation

    To install the extension:

    * Download the XPI file of the [latest release](https://github.com/UB-Mannheim/zotero-ocr/releases).
    * In Zotero, go to Tools → Add-ons and drag the .xpi onto the Add-ons window.
    * Possibly, adjust the path to Tesseract in the add-on options.
  • To be more clear, I have copied the pdftoppm file into every directory I can see that is related to Zotero, and no change.

    To what directory for a pdftoppm executable is it referring?
  • For what it is worth, I think the directory on my installation is:

    /home/USER/.local/share/flatpak/app/org.zotero.Zotero/x86_64/stable/021402b4c4c3e353f1e2346f4b2408bdca37cc1ffe6851a6209b3b1e7daad4f0/files/share/zotero
  • edited 21 days ago
    I'd be surprised if the app was tested using flatpack installs of Zotero, so might just be that, but have you tried the path specified in the error message, ie. /app/share/zotero/pdftoppm
  • edited 21 days ago
    Given that it doesn't exist, no. In any case the directory above worked.
Sign In or Register to comment.