Error saving with Wiley Online Library

edited 24 days ago
Trying to import from Wiley Online Library I get an error
"An error occurred saving with Wiley Online Library. Attempting to save using Atypon Journals instead."
But then nothing happens, i.e., import fails completely. (and the little notification message stays on the site until refreshing)

Some people had reported this last year, see here
https://forums.zotero.org/discussion/77276/connector-not-working-with-wiley-website
and here
https://forums.zotero.org/discussion/77655/zotero-connector-failed-on-wiley-journal


Some examples of papers that don't work:

https://onlinelibrary.wiley.com/doi/10.1111/cob.12406

https://anthrosource.onlinelibrary.wiley.com/doi/full/10.1111/aman.13471

(for me at the moment no Wiley import works.)

Any help figuring out what's wrong much appreciated.

  • Both of these work for me. Could you run through
    https://www.zotero.org/support/troubleshooting_translator_issues as they apply and provide a debug ID for a failed save attempt (as per the last step) if none of them help?
  • A couple of days ago, for awhile, Wiley pages didn't completely load until almost a full minute had elapsed. @jandavid should try again. I have not noticed a slow-down lately.
  • Unfortunately, it still doesn't work. Unless today there's a new slow down with Wiley my problem must be different.

    Following instructions on the troubleshooting page, I've tried all (applicable) steps but nothing helped.
    Thus here my debugging info:

    URLs that don't work:
    https://onlinelibrary.wiley.com/doi/10.1111/cob.12406
    https://anthrosource.onlinelibrary.wiley.com/doi/full/10.1111/aman.13471

    Debug ID: D121819482

    Popup: "An error occurred saving with Wiley Online Library. Attempting to save using Atypon Journals instead."
    Then nothing happens.

    Name of translator: "Wiley Online Library".

    Thanks for looking into this!
  • @dstillman anything in the debug?
  • The BibTeX translation is failing.

    @jandavid, on that page, if you go to Tools → "Export citation" and choose "BibTeX" and "Indirect import", and then click Download, what do you see?
  • (I'm wondering if they're getting the same cookie error that I saw in scaffold [where manual download of the bibtex worked fine]?)
  • There was a previous thread from 2018 where somebody wasn't getting served proper BibTeX from Wiley when Firefox was set to block all third-party cookies, though I'm not sure why that would be relevant, since the citation-download endpoint is on the same domain.
  • @dstillman
    Sorry, did you mean the Firefox Tools menu? I don't see "Export citation" there.
  • On the Wiley page
  • Yes, I'm on the Wiley page.
    But the Firefox Tools menu only shows me
    Downloads
    Add-ons
    Web developer, and
    Page Info

    Also, in regards to @adamsmith's comment, I tried to allow all cookies in the Firefox preferences, then reloaded the Wiley tab and I'm still getting the same error.
  • No, literally on the Wiley page. Not the Firefox Tools menu.
  • edited 20 days ago
    Oh, I see, sorry.
    When I do that I get the raw BibTeX entry.

    @article{doi:10.1111/cob.12406,
    author = {Grannell, Andrew and le Roux, Carel W. and McGillicuddy, Deirdre},
    . . .
    (all the intervening lines)
    . . .
    }

  • And you still get the error saving?
  • Well, when I'm on the BibTeX download page, then obviously the import works.
    But when I return to the Wiley article page I get the error.

  • BTW, upon returning to the article page, the first time I click the Zotero importer I get the popup for a second or two (only saying Saving to, without the translator displayed and without the title or "An error occurred ... Attempting to save ...") and it disappears and nothing happens.
    When I reload the page I then get the error popup.
  • Right, I'm asking about the article page. The point is just that the error you're getting would be from your not getting served the BibTeX data during the save process, even though you apparently can view it properly manually.

    Have you tried from a different browser?
  • If you're running any other browser extensions in Firefox, you should also try with those disabled.
  • edited 20 days ago
    You could also try in a new Firefox profile (and delete it after). There's just a very good chance this is something about your current Firefox profile.
  • OK, so I have now tried to disable every other browser extension except for Zotero ... still the same problem. Tomorrow I'll try to both, install the Zotero plugin for Safari (I'm usually only using Firefox hence there was no need before), and also creating a new Firefox profile to see if I can narrow down the problem. I'll post back.
    Thanks for your help, it's very much appreciated :)
  • You'd want to try Chrome, not Safari. The Zotero Connector situation for Safari is currently complicated, so Chrome and/or a new Firefox profile are much easier.
  • @dstillman
    OK, so I have now installed a new empty Firefox profile, with noting except for the Zotero Connector.
    Still the same problem :(

    Here's a new debug ID D2139955896 with the new profile, in case it is of any help ...

    Oh, and I don't have Chrome installed, so won't be able to test that.
  • are you getting access to the article through your institution? If so, how (are you on campus, VPN, proxy, something else)?
  • I do have a VPN set up but it's not connected.
  • FWIW I now did connect through VPN and tried to import. Same error ...
    None of this seems to make any difference. Any other idea what could be wrong?
  • What Firefox version are you using? Grasping at straws here -- I don't really understand why you'd be seeing anything different than us.
  • The latest version, 80.0.1
    likewise at a loss what else to try ...
  • edited 19 days ago
    I now fully uninstalled Zotero, deleted the Zotero folder, and did a clean reinstall. Problem solved.

    I then manually reconfigured it the way I had it, testing frequently after every setting and every added add-on. I'm now back to (I believe) exactly the same configuration that I had before things broke. And it still works. So I can't say I figured out what caused the issue, but glad it's fixed.

    The only thing I can say is it was not with the Zotero connector but with Zotero itself (I did not uninstall/reinstall the connector). Still puzzled wha the problem could have been.

    Thanks for all your help.
  • The only thing I can say is it was not with the Zotero connector but with Zotero itself
    The translation takes place in the Zotero Connector, not in Zotero, and the error you were getting was in the Connector, before it even tries to send the data to Zotero.

    You did have an outdated version of the Wiley translator, suggesting that there could be a problem updating translators in your Zotero. But even that shouldn't really be relevant — the only update to the Wiley translator since yours was a few days ago, and it wouldn't have affected this.

    In any case, there was certainly no need to reinstall or delete the Zotero folder (which folder?), and that's not something we recommend doing unless we explicitly suggest it here, which is very rare. The only thing that really could've even possibly affected this, if you mean that you deleted your Zotero data directory, is the 'translators' folder, and that would've been cleared if you reset translators, which was one of the troubleshooting steps I linked to above.
  • Ha, I guess we now solved the mystery. :)
    If you saw I had an outdated version of the Wiley translator, then that must have been the problem.
    Because I precisely didn't do step 13 in the troubleshooting guide as I thought that wasn't applicable in my case. It says "In rare cases where you're seeing a webpage icon on all sites or saving is failing on all sites ..." I didn't see any webpage icon and it was also only the Wiley site where saving was failing. And it also says "This isn't necessary as a regular troubleshooting step" so I skipped that as I didn't think that would have anything to do with it.
    Hence I went ahead and just deleted the whole thing (yes, the Zotero data directory – I then restored things step by step) as I just couldn't figure out what was wrong – so that cleared it up. Might have not been necessary, but, oh well.
    So glad it's fixed now...
Sign In or Register to comment.