Missing information when citing in APA

This discussion was created from comments split from: Changes to APA Style in 7th Edition.
  • I'm a university student trying to use APA style in my report in Word. When I cite a document and I input the citation manually I have the publication date and author name. The problem only arises when citing a book found online, I do not get the information even though through the Zotero program shows it does exist in this format.
    Example of book citation in Word:

    Project Management: A Practical Approach. (n.d.). Retrieved September 2, 2020, from http://www......

    Example when accessing the style from printing to PDF:

    Grit, R. (2015). Project Management: A Practical Approach: Vol. Fourth edition. Noordhoff Uitgevers BV. http://www......

    I double-checked that the information is input correctly into the Zotero program, it just does one format for Word (with the Zotero add-on), and another when printing to PDF. I would like to get the PDF information displayed in Word. Is there something I need to change in the settings to get all the information displayed in Word?
  • How exactly are you using the Word add-on? This sounds like you're either citing a different item or an attachment.
  • I have the Word Zotero add-on, I click the Add/Edit Bibliography button. I just can't figure out why the add-on produces a different output than going through the Zotero program and printing to PDF. As I mentioned, I only have this problem when citing an online textbook like this. I successfully cited documents and webpages.
  • For clarification, to print to PDF and get the output I showed, I right-click on the item in the Zotero program window and select Create Bibliography From Item. I make sure the settings are for APA 7th edition.
  • Still the same answer — you're citing a different item. You can test this in a new document. If you select the same item from your library and the same style, you will definitely get the same output.
  • So I tried just deleting it from my library in Zotero and reapplying the same method. This time it worked. Thanks for the help, adamsmith and dstillman.
Sign In or Register to comment.