Zotero plugin fails with LibreOffice 7.0

edited August 8, 2020
Just downloaded LibreOffice 7 (7.0.0) and tried to have zotero install plugin. Install failed.
Reported to devs as Report ID 376333042.

LO7 identified Oracle Java 14 and 14.0.1 as "defective" (though they work fine with LO6.x) - might that may have something to do it...

[JavaScript Error: "TypeError: temp is null" {file: "chrome://zotero/content/bindings/preferences-mac.xml" line: 1225}]

[JavaScript Error: "uncaught exception: unopkg at /Applications/LibreOffice7.app/Contents/MacOS/unopkg failed to install"]

version => 5.0.89, platform => MacIntel, oscpu => Intel Mac OS X 10.15, locale => en-US, appName => Zotero, appVersion => 5.0.89, extensions => ZotFile (5.0.16, extension), Zutilo Utility for Zotero (3.5.0, extension), Zotero Word for Mac Integration (5.0.27.SA.5.0.89, extension), Zotero LibreOffice Integration (5.0.23.SA.5.0.89, extension), Shockwave Flash (, plugin)
  • The LO plugin works fine for me with the standard Mac JRE download of Java 8. Are you running the full JDK?
  • edited August 8, 2020
    But this seems like more a question for LO. Zotero's LO plugin requires a functioning Java install, so if LO is listing your Java version as "defective", that's certainly the problem.

    If you're just trying to get the plugin working, though, and don't need Java for anything else, I'd switch to the default Java 8 JRE.
  • Running full 14.0.1 oracle JDK
    Have reported to LO but don’t expect much in the way of response. LO thinks they have solved all Java issues :-(
    As 8 presented security issues I went ahead in LO6.x and moved to Oracle Java with no problems.
    I just posted here in case other Zotero users who updated their java planned on moving to LO7

    I am going to try a few things and will update this thread if I have any success
  • Actually, I don’t think the Java updates change the Java internet plugin which is likely still at 8
  • How did 8 present security issues? It’s the current recommended release of Java for Macs. The latest release is from a few weeks ago.
  • That was some time ago...
    Maybe I felt pressured by the repeated statements that 8 would no longer be supported?
  • Yeah, I don't understand what the deal is with their versions, but it seems like 8 is the JRE version they offer and maintain for all platforms.
  • edited September 29, 2020
    I filed a LibreOffice bug and then discovered a previously filed bug at https://bugs.documentfoundation.org/show_bug.cgi?id=135479

    For those concerned, I installed Oracle Java 12.0.2 from the archive and LO7.0.0 recognized and used this java. Other users have noted that OpenJava 12 also works.

    So, it would seem that the issue may well be that someone tweaked the code that first checks java when LO7 comes up and I have requested that the bug be assigned to whomever last touched that code as I am hoping it is a very simple fix.

    In the meantime, LO users who were using Java 14 can install java 12 to work with it pending a fix
  • Just to update this for others, it seems like LibreOffice on macOS does currently require a Java JDK, not the Java 8 JRE, and LibreOffice 7 works with JDK versions up to 12, not newer versions. (Our troubleshooting documentation said the JDK was required on macOS 10.11 and up, but I was testing this wrong.)

    On Windows, the Java 8 JRE works fine.

    So, as @netbuoy said, you should install JDK 12 for now if you want to use the LO plugin on macOS.

    Sorry for the confusion.
  • @dstillman The system requirements page for Zotero has noted that the JDK is required on Mac for some time now.
  • edited September 29, 2020
    @bwiernik: No, it didn't — I just added that today. It just said LibreOffice required "Java Runtime Environment (JRE) or Java Development Kit (JDK)".
  • @dstillman
    Yes. Two separate issues, one having to do with where the JDK is located (JRE not adequate) that can be found at https://bugs.documentfoundation.org/show_bug.cgi?id=135462 and one that addressing failure to source JDK 14 which is found at https://bugs.documentfoundation.org/show_bug.cgi?id=135479 . Both have been fixed. The fixes will appear in LO 7.1
  • edited November 20, 2023
    For me, installing libreoffice java wrappers did job. I faced similar problem in Ubuntu so I referred to https://ask.libreoffice.org/t/java-jre-not-found/55956/2 .
    After `sudo apt install libreoffice-java-common` JRE appeared in LO/Tools menu/Options.../Advanced.

    I have also added JAVA_HOME global variable and prepended $JAVA_HOME/bin to the $PATH, but is not necessary if one use new Java version.
Sign In or Register to comment.