Lost attachments in a group

This discussion was created from comments split from: Lost attachments (PDF and others).
  • I'm having a similar problem with a "Group". I'm the only member of the Group, and I do not sync between computers. All the attachments went missing after one restart, but when I search for the pdf in the storage folder of zotero, they are still there. It seems that the database was broken for this group, and zotero could not link the attachments to the reference items. I could not fix it, but fortunately, I didn't have too many items in that group anyway. I exported the group, deleted the group on zotero.org, created a new group, and manually searched for all the attachments in storage and put the attachments back.
  • (Please start new threads for new issues — the thread you posted to was eight years old and was specific to someone else's issue. I've moved this to a new thread.)

    This is likely some sort of misunderstanding, and what you did almost certainly made things worse by creating lots of orphaned files in your data directory. I'd strongly encourage you to post here before trying drastic troubleshooting steps.

    If you have a backup of your data directory and want to debug this properly, we could walk you through it, but otherwise there's not much we can do, so I'm not sure what you're looking for by posting here now.
  • (Actually, we couldn't even debug this now, since you deleted the group.)
  • Thanks a lot for offering to help. I do indeed have backups.
    As I mentioned, what I tried was to export the group, delete the group, make a new group, import everything back. The "delete the group" step actually failed, and I moved on anyway. I tried to copy some folders from this group library to "My Library", and zotero some how managed to reestablish attachment links of the citation items in My Library.
    Now it is quite a mess, and I just realized that I should have looked for help before going through all this meaningless work.
    This is the second time that this bug occurred to me, but I still can't figure out what triggered it. The phenomenon would be: The group library lose all attachment links, can't drag new attachment to the group library, can manually create new citation item, can't manually add attachment to existing or newly created citation item.
  • This wouldn't be a bug in Zotero. Stored files are just files within the Zotero data directory in folders named after the item key, and there's simply no way for them to become inaccessible on the same computer unless you delete them outside of Zotero or do something else with your data directory (e.g., move it elsewhere and then lose the setting pointing to it, place it in a cloud storage folder, try to symlink the 'storage' subfolder and then move the target folder).
Sign In or Register to comment.