A particular citation bugged in a strange way

edited 10 days ago
I imported the following citation to Zotero 5.0.89 from Chrome using the "Save to Zotero" addon:

https://www.nature.com/articles/nphys1301

(though Zotero routed it through my uni's proxy). If I try and export this to biblatex (choosing UTF-8) then compile via biblatex, I get

>Package inputenc Error: Invalid UTF-8 byte sequence

One of the authors names has a ö character in it, and if I delete that ö then everything compiles no problem. If I re-type the ö using the Microsoft International keyboard, then I will get the same error. The strange thing is, this happens only with this one citation. If I go to any other of my Zotero entries, type in an ö using the Microsoft keyboard, then export, it will compile just fine.

There is something about that particular citation that means it won't accept the ö character, but I can't figure out why that would be. I have deleted the citation from my library and re-imported it using Zotero, same result both times.

Here is the full citation exported from Zotero (minus the file field)

@article{groblacher_demonstration_2009,
title = {Demonstration of an ultracold micro-optomechanical oscillator in a cryogenic cavity},
volume = {5},
issn = {1745-2481},
url = {http://www.nature.com/articles/nphys1301},
doi = {10.1038/nphys1301},
abstract = {Cooling optomechanical resonators to their quantum-mechanical ground state could enable the observation of quantum effects in macroscopic objects. The experimental cooling of a 43-ng silicon-nitride beam to a thermal occupancy of just 30 indicates that this ultimate goal is not too far away.},
language = {en},
number = {7},
urldate = {2020-08-01},
journal = {Nature Physics},
author = {Gröblacher, Simon and Hertzberg, Jared B. and Vanner, Michael R. and Cole, Garrett D. and Gigan, Sylvain and Schwab, K. C. and Aspelmeyer, Markus},
month = jul,
year = {2009},
note = {Number: 7
Publisher: Nature Publishing Group},
keywords = {thesis},
pages = {485--488},
}
  • Have you tried manually adjusting the biblatex (by re-typing the ö)? If that doesn't fix the issue, this would seem to be a biblatex rather than Zotero issue, no?
Sign In or Register to comment.