Unkown format token name

I recently get the message 'CSL processor error: unkown format token name: macro-with-date' when I try to add the bibliography...
Can someone help me with this?
  • Which citation style are you using?
  • Now APA 7 (but I think it changed during my writing; its a PhD so I started with it 2 years ago, and now I have the problem)
  • I have the same problem, but with a newer document (created and last updated beginning of July 2020), which suddenly does not work anymore.

    I haven't changed neither the citation style nor something else, just wanted to refresh the citations and edit one.

    Would be also grateful for some help.
  • edited July 14, 2020

    I am getting the exact same error message with APA 7.
    Ain't working with either an old or brand new microsoft word document (just tried to add a citation on a blank sheet).

    Any help would be very much appreciated indeed!
  • edited July 14, 2020
    It seems to be a problem with APA 7, indeed. My document was in APA 7 as well.
    When changing into a different style, the problem disappears. When changing back to APA 7, the problem is back.

    However: APA 7 worked fine for me until now. It was updated just yesterday, so maybe the person responsible for updates of this style might fix the bug.
  • The change yesterday was very minor and I don't think has anything to do with that.

    This is the penultimate version of the style. Give it a try, but it doubt it'll make a difference: https://raw.githubusercontent.com/bwiernik/styles/1acd5b9eb6774fb7f2f63e5bdb06d3c1e6bc1e8d/apa.csl (right click, save as, install via double click or menu)
  • Hi damnation,

    thanks a lot for sending the penultimate style version. It works! :-) I don't receive error messages any more.

    Kind regards, M.Schlöffel

  • If we could get from everyone in this thread:
    - Zotero version
    - Operating system
    - language in which you use APA
    - Whether this happened in a new document like @creupelandt mentioned

    As damnation says, there shouldn't be anything in the updated style that makes any difference and I can't replicate the error with the current version.
  • Hello,

    I'm using version standalone version, on a Windows 10 pro system (64 bit).

    Yes, it happens in a new document as well, like @creupelandt mentioned. Unfortunately Zotero has just updated my APA7, so I will have to install (and maybe rename?) the penultimate version again.

    The language I normally use is German, but I just tried it out with English(UK) and English(US) and received the same error message.

    Just getting more curious, what the error might be ;-)...

    Regards, M.Schlöffel

  • I'm using version standalone version, on a Windows 10 pro system (64 bit).
    Start by updating Zotero. You should use the most recent version, 5.0.88
  • I have got the same message 'CSL processor error: unkown format token name: macro-with-date' today and now I don't know how to fix this. I have searched the phrase and reached to your post. I cannot edit citations, insert new citation, cannot change document preferences or insert bibliography. The same message opens up :(
  • In order to troubleshoot this, please follow what adamsmith wrote here:
  • If someone is experiencing this on Zotero 5.0.88 and is able to provide an example document where this occurs, please either upload it somewhere (e.g., Dropbox) and provide a link or email it to support@zotero.org with a link to this thread.
  • @adamsmith Thanks a lot for your quick answer. I've involved our IT-team, since our Zotero updates are launched centrally. As soon, as the update has been successful I will check if the problem disappeared and give you a feedback.
  • Any news yet? Still not working...
  • I am using zotero; word for mac:2011 14.7.3
  • You're using a long-outdated and no-longer supported version of Zotero. Update to 5.0.88 (you can update simply by re-installing) and this will almost certainly fix itself.
  • @adamsmith Sorry for the delay. My Zotero is updated to version 5.0.71 now (our institution does not support the latest version, unfortunately).
    But the problem does not occur anymore. However, I have found out that I have to turn out the "track changes" mode in Word. Otherwise Zotero does not work properly.
    Again thank you for your help.
Sign In or Register to comment.