Zotero freeze Nautilus

Under GNU/Linux, Zotero freeze Nautilus. Is there any solution ?
  • Are you running the official Zotero tarball, or are you running a third-party package?
  • I'm using the official tarball 5.0.82 under Ubuntu 18.04
  • The latest version is 5.0.88. Start by updating to that, though it's unlikely to fix this.

    What exactly are you doing when Nautilus freezes?
  • Now it's 5.0.88 and the problem is the same.
    When I want to «drag and drop» from Nautilus to Zotero I have to close Zotero and «drag and drop» very quickly when zotero started because Nautilus freeze in 5 or 6 seconds. When I close Zotero, Nautilus wait 10 sec and work again.
    This problem exist for 3 years with all versions of Zotero or Nautilus onto Ubuntu since 16.04.
  • Could you produce a Debug ID from Zotero when the freezing for Nautilus occurs? Do you have a SSD or HDD for the storage medium on this computer?
  • I have this debug number : 1204152014
  • I have HDD for the storage (/home) and SSD for the core (/)
  • That's a Report ID, we'd need a Debug ID as described in the article linked above.
  • The Debug ID is D1658654783
  • Wait, you're getting a freeze in Nautilus just by opening Zotero? Not by actually trying to drag anything to Zotero? And it's resolved by closing Zotero?
  • Yes, that's what happens exactly
  • Does it freeze Nautilus regardless of which directories you're browsing or are those somehow related to Zotero?
  • Nautilus simply does not work if Zotero is running. It means you cannot use Nautilus GUI until you close Zotero. Right immediately you close Zotero, then Nautilus works again. It basically means, that this bug is not due to what you were doing on Nautilus. The bug comes just because you open Zotero (it is not related with any user operation under Nautilus).
  • How are you launching Zotero? From your launcher or from the terminal? Does it make a difference?
  • 1. Open Zotero from a launcher: I have a '.desktop' launcher with the command: "Exec=/home/my_user_name/MyApps/Zotero_linux-x86_64/zotero" and it gives the behavior mentioned before.

    2. Open Zotero from terminal: when running from the terminal with './zotero' it becomes really crazy, because Nautilus will never work again until you restart the computer. Even thought in the system monitor there is not Zotero running, Nautilus is not working anymore until the next restarting. The message I got when I run Nautilus from the terminal is:

    Nautilus-Share-Message: 12:15:59.253: Called "net usershare info" but it failed: Failed to execute child process “net” (No such file or directory)

  • Please omit that message from running nautilus from the terminal. I always have this message, but Nautilus works normally.
  • Are you also using Ubuntu? This seems like some sort of bigger OS level corruption. I run Ubuntu 18.04 (and have run all the previous LTS versions) for Zotero development daily and have never had issues with Nautilus while running Zotero either from the terminal or the launcher.
  • I am using Ubuntu 20.04. Yeah. It is pretty strange
  • Sorry to revive the thread, but I'm on Fedora 36 w/ Gnome and having the same issue. Did anyone here ever happen to find a solution?
Sign In or Register to comment.