Zotero Not Syncing - internet connection

Hello,

My Zotero has just stopped syncing. I get the red circle exclamation on the left of the green arrow circle. It states "Error connecting to server. Check your internet connection". However, I have internet connection.

I added Zotero to my list of "allowed" incoming connections - problem still persists.

I tried troubleshooting by following Zotero's instructions. I click the More Information button, and it sends me to "Error connecting to server. Check your Internet connection." (https://www.zotero.org/support/kb/connection_error) in Zotero website. I tried disabling my firewall, restarting Zotero - problem still persists. I went to Zotero Preferences > Advanced Pane to look for Config Editor. However, I don't see Config Editor.


I use a Mac and have used Zotero on this Mac for more than a year now and never encountered this problem.

Thanks in advance!
  • Which Zotero version are you using? The Config Editor has moved around some, but it's definitely in the advanced pane of the preferences.

    That said, you shouldn't need it if you're not using a proxy server. Have you checked your certificate as per the last link on the troubleshooting screen?
  • The Zotero version I'm using is 5.0.88. And I don't know how to check the certificate.
  • https://www.zotero.org/support/kb/ssl_certificate_error has fairly straightforward instructions with further links (generally documentation pages rely heavily on links to provide explanations or further instructions -- don't ignore them). If something isn't clear, you'd need to say what and we can explain.
  • edited 14 days ago
    Sorry, this is a very simple question. I'm following the instruction on https://www.zotero.org/support/kb/site_certificate_info to view the issues.

    I am seeing Issue by: Apple and there is no Issue to: line.

  • On the left of the URL/Address bar. See https://imgur.com/pnHS422 for a screenshot
  • edited 14 days ago
    Found it. Thanks. Sorry, was late in replying. I see Issue by: Let's Encrypt Authority X3 but no Issue to: line.
  • You're seeing "Issued by" Apple for zotero.org (i.e. once you've navigated to zotero.org and clicked the padlock icon there)? That's not right.

    What do you see on other sites like google.com?

  • edited 14 days ago
    Sorry, I later went to Zotero.org and got this: Issue by: Let's Encrypt Authority X3

    Afterwards, I went to my Zotero app > Preferences > Advanced to look for Config Editor. But I can't find Config Editor in that window. Please see: https://imgur.com/a/R0cumJO
  • OK, so that's right.

    Let's return to the issue of proxies: Do you know if you're using a proxy server to connect to the internet? Do you manage your own computer/internet connection or is this maintained by corporate/institutional IT?
  • It's maintained by an institutional IT - university.
  • I'm following the instruction (https://www.zotero.org/support/kb/ssl_certificate_error) 3.II. And I'm guessing that my institution is blocking Zotero's access to the internet. So, I contacted my school's IT Department to see if they can unblock Zotero.

    Am I correct in this?
  • edited 14 days ago
    I would focus on Connection Error, not SSL Certificate Error. It's more likely to be a proxy issue. It's not about blocking Zotero.
  • Yeah, however, I can't see the Config Editor in the Advanced panel of Zotero Preferences. Do you have any idea why this is and where I can go to find this Config Editor. I've been searching the Zotero app and can't seem to find it.
  • There's a Config Editor button right in the screenshot you posted above.
  • OMG, I'm so sorry. I didn't read well. That fixed the problem. Thank you!
  • What did you have to change, out of curiosity?
Sign In or Register to comment.