Window text and font are so large I cannot use Zotero

I'm having a huge issue with the size of font in the Zotero window on my MacOS desktop computer. When opening the program I cannot access any of the features or functions. I've tried reinstalling Zotero, reinstalling macOS Catalina, and adjusting the resolution on my desktop. Nothing seems to be adjusting the Zotero font and window. Please Help!!
  • You can adjust the font size from the View menu, but that only would've changed if you had changed it to begin with. If you View → Font Size → Reset doesn't work, can you take a screenshot of what you're seeing, upload it somewhere, and provide a link here?
  • I have tried to troubleshoot every possible way to reset Zotero and my safari display preferences. Here is a link to screen shots of what the issue looks like on my end.

    https://docs.google.com/document/d/1YHYpAGluz4htXxQ0CUsNTUqCjQFf_BdgUAouhi5eVgs/edit?usp=sharing

  • Is this an iMac, or are you using an external monitor? Is this a Retina display? What's your screen resolution? Are you using two monitors?

    Has Zotero ever appeared correctly on this computer? If so, what changed between the last time you used it and now?

    Close Zotero, go to your Zotero profile directory, and open prefs.js in TextEdit. Do you see layout.css.devPixelsPerPx in that file? If so, what is it set to? If not, add this line and save the file:

    user_pref("layout.css.devPixelsPerPx", "1.0");
  • I just followed the profile directory instructions, added the user_pref line and saved then reopened Zotero and the issue wasn't resolved.

    I'm using a MacOS desktop with Retina display at default which should be 2048 x 1152, I'm using one monitor. I have Zotero on my MacBook Air as well and have never encountered this issue on my laptop. Zotero continues to work on my laptop it is the desktop that is giving me issues. Zotero did operate correctly on this desktop computer and stopped working at random. I have updated my software operating system and restarted the computer several times, as well as deleted and re-downloaded Zotero.
  • Can you close Zotero and email us the prefs.js file at support@zotero.org with a link to this thread?
  • Thank you I have sent an email with information above.
  • You have that line appearing a couple times in prefs.js. You should remove all but one of them (again, with Zotero closed), and then try with "0.5". If there's no difference, that's very odd, but you should then delete the line.

    But while that line should definitely affect the sizing, the default (with no line) really should work. No one else has reported this, so this is almost certainly some configuration issue on your computer. If you go to System Preferences → Displays, what settings are in use, and does changing them and restarting Zotero make any difference? Are you using any accessibility feature on your computer that would change how things are displayed?
  • It must be an issue with my Mac. I've removed the line and adjusted the number to 0.5 and still no difference. I will move onto Apple support as it may be an issue from the latest Catalina update.
Sign In or Register to comment.