Can't use LibreOffice plugin

This discussion was created from comments split from: RTF/ODF Scan for Zotero.
  • I am unable to set the citation style in Libre Office. The Zotero plugin icons are visible but not active, that is, if I click on them they do not drop down any options or respond. I have tried over the last few years to use this RTF-ODF function with Scrivener and Zotero, but have not succeeded. Now that I need to format many footnotes for my PhD dissertation I am trying again. Please help.
  • As per the previous comment, here is the step in your RTF-ODF instructions that I am stuck at:

    Setting a Citation Style
    Now open the converted document — by default it will have (citation) in its file name — in LibreOffice. In the toolbar of the Zotero LibreOffice plugin, click the Set Document Preferences button and choose a citation style. Click OK and Zotero will format all references in your document. If you want a bibliography, move the cursor to the desired location and click Insert Bibliography.

    I can't get any of those Zotero buttons in Libre Office to do anything. I do have 'live' reference fields in the footnotes, however, which is further than I have ever got before.
  • Can you elaborate the exact steps you are following?

    * In scrivener, export to ODT (with RTF/ODF scan marks in the text)
    * Open using RTF/ODF scan
    * ?

    Or

    * In scrivener, export to RTF (with RTF/ODF scan marks in the text)
    * In LO, save as ODT
    * Open using RTF/ODF scan
    * ?

  • I cannot see RTF/ODF scan: only RTF on one line, and then *two* ODFS on the next two lines (I think I installed it twice). I have never (over some years) managed to get RTF/ODF scan option installed in Zotero. This time, as before, I had to install Java, that may or may not have worked... there was some kind of error message (sorry I can't recall the exact steps).
  • I don't understand what "line" means in this context, or what "installed twice" means. Where do you see these lines, and what do you think you have installed twice?
  • Oh, I think I understand. RTF scan is built into Zotero. ODF scan is from the plugin. Which will work for you depends on what kind of marker you have inserted. RTF-scan markers look like {Smith, 2009}, ODF-scan markers look like { | Smith, 2009 | | | zotero://.... }. Which of those two do you have?
  • This paragraph in your RTF/OTF instructions page seems to be outdated now:

    "Then, select RTF/ODF Scan in Zotero's gear/action menu. Select ODF (to citations) as file type, select your saved .odt file as the input file, and set a target destination for the output file. Finally, click Next to convert your document."

    There is no gear/action menu in my Standalone Zotero. Where do you mean? I guess I worked it out once to get this ODT (citations) draft doc that I am now looking at, but I can't recall where to do it.
  • Ah, I see there is an RTF option in the dropdown menu under under Tools, and also an ODF option. These are not combined as RTF/ODF. Should they be? This is where I think I have got stuck before... unable to get RTF/ODF together.
  • I see in the Cite tab of Zotero preferences (under Wordprocessors) it tells me that Libre Office add-in is not installed and prompts me to install it. So I click on that, and it comes up with an error message saying:
    "Installation could not be completed because an error occurred. Please ensure that LibreOffice is closed, and then restart Zotero."
    Well Libre Office is closed. But there is another dialog box suggesting I install manually. So I follow those instructions, double click the extension, and up comes a box that says:
    "You are about to install version 5.0.21 of the extension 'Zotero LibreOffice Integration'.
    That version is already installed.
    Click 'OK' to replace the installed extension.
    Click 'Cancel' to stop the installation."
    I click OK and up comes a box that says:
    "Could not create Java implementation loader".
    So that's the end of the line, it seems. Java is the problem?
  • Sorry, it didn't update with your reply here, so I didn't see it. I have this kind of scan marker { | Jarvis, 1936 | | |zu:568285:UAXZUWFG}
  • That's ODF scan, and indeed, the scan options have moved to the tools menu. For those markers, you need to export to ODT from Scrivener, and then select "ODF Scan" from the Tools menu.
  • (I'm not part of the Zotero crew BTW, I was initially confused by "your instructions", I thought you were referring to something I posted on the forums maybe)
  • edited 27 days ago
    Ah, OK, so that's what I did (for lack of a combined RTF/ODF scan option). And then I got a Libre Office (citations) doc with live footnote fields! But then, as explained above, I have 'dead' Zotero buttons. Seems I cannot properly install the Libre Office add-on. It seems to end up in a Java problem. I have freshly installed Java, and followed a prompt to 'configure' it. But still no luck.
  • That's outside my area of expertise, I don't really use Java, LO or Word unless I really, really must. The Zotero crew will likely chime in on that.
  • Thanks for your explanations to this point. I am inserting the footnotes manually in Word, as I have done for years :-( I can't give up on Scrivener for writing, could never go back to Word for managing such a large complex text. But the interface with Zotero via Libre Office is so far too hard for me.
  • I don't think you're supposed to add footnotes manually. Zotero via LO should be frictionless (I occasionally test it for my markdown -> Zotero workflow), but I don't know how the Scrivener export figures into that.

    What makes Scrivener so good for writing academic texts? I have tried Scrivener years ago but just a week or so. Nothing stuck with me as being very special. Although I can easily understand not wanting to write large chunks of text in Word/LO, but for that, I use LaTeX (for clarity, I wouldn't recommend switching to LaTeX if you have tools that you're used to which do what you need)
  • No, I am adding them manually in Word because I can't get the Zotero buttons to work in Libre Office.
  • I guess I am just used to Scrivener, and now in a PhD can't risk trying to switch tools. Never heard of LaTeX.
  • No idea why that would be the case. I can open live LO documents without issue (I'm on a Mac and Linux, not sure if the experience differs per platform)
  • Absolutely do not switch to LaTeX unless there's a pressing reason to do so. I'm used to LaTeX which makes it my default choice, but it's not something you want to get into under time pressure.
  • I think it is because I can't install the Libre Office add-on to Zotero. I get error messages, have to try to install manually, and then I get another (Java) error message. It has been doing this to me for five years through three different laptops, so I don't understand it.
  • @debhurn -- this doesn't actually sound like it has anything to do with the ODF Scan add-on. The problem is that you can't get Zotero's LibreOffice integration installed. Make sure you've carefully run through all relevant troubleshooting: https://www.zotero.org/support/word_processor_plugin_troubleshooting#installation_error and then start a new thread, and include information of your exact set up (Zotero versions, OS, LibreOffice versions) as well as the specific troubleshooting you've performed and with what results.
  • Thanks, Adam. Yes I worked out it was a problem with the Libre Office add-on. I also found that document you linked to, and began to work through the instructions. I ran into a warning about closing Libre Office because of some conflict (can't recall exactly what it said) and said if I continued I would damage my Zotero... but this was when all Libre Office docs were closed. So I have uninstalled LO, even though it was a fresh install today, and will have to give up for now. I can't risk damaging my Zotero at this stage so late in my PhD writing. 1000s of references, I would end up in a strait-jacket and a padded cell!
  • But I will have to try again soon, because I can't enter 1000s of footnotes manually in Word after I export from Scrivener :-/
  • (if it's any consolation, a PhD usually involves a straitjacket and a padded cell at some point, but preferably because you underestimated the size of the task, not because your tooling thwarts you)
  • As you continue, noting down the exact text of warnings such as
    I ran into a warning about closing Libre Office because of some conflict (can't recall exactly what it said) and said if I continued I would damage my Zotero
    is going to be important.
    I'm fairly certain that there is literally no way -- and definitely no error message -- that you're going to damage Zotero by doing anything in LibreOffice, so you're likely misunderstanding something there, but we'd need the exact text for that (and, please, in a new discussion).
  • @debhurn: I've moved this to a new thread, since it had nothing to do with the other one.

    You can continue posting about this issue here.
Sign In or Register to comment.