SOLVED: ASCE: use the embedded metadata as the default translator

edited July 3, 2020
EDIT. I changed the title of this thread because the problem has been solved. Thank you

I recall that this issue has been brought up before but I wonder if there might be anything that can be done to remedy the confused metadata from the publisher. For some authors it is possible to edit the name order by converting from single-name to last-first and then swapping first and last names. However, for many, if not most, some of the author names are not parsed properly and the conversion doesn't result in the authors' real names.

Three examples:


Please know that I have written to the editors asking that they use any influence to urge the publisher to fix this problem. I didn't mention Zotero but wrote of this being a general problem with all personal bibliography management software. I received a reply that their BibTeX export might work better than RIS. At the time, the BibTeX was still wrong. I wrote back with examples of the problem.

Currenty, the RIS export is formatted incorrectly as is the webpage header. However, the BibTex export when imported into Zotero results in the correct author names.

I don't recall if the journal Impact Factor calculation involves author last-name. If it does include the author name in the matching process this might be another argument for the publisher to want to make the change.

  • Importing using embedded metadata seems to work, no?
  • edited June 19, 2020
    Embedded metadata is a good way to bring in all of the authors' names in the proper format and the abstract is also imported. However, the abstract is imported with the word "Abstract" at the beginning of the text with no space between "abstract" and the first word of the abstract text.

    [edit: I now see that only the first 150 (or so) characters of the abstract are included and that I must paste the abstract from the website to have the whole thing.]

    Is is possible to use the embedded metadata as the default translator instead of the current one. The current translator doesn't bring in the abstract and imports the author names in single-field mode.

  • @adamsmith
    How can this be brought to the attention of the person responsible for setting the default translator for a journal? I can right-click and select embedded metadata from the dropdown but that is tedious considering that the current default translator imports flawed author names and the embedded metadata option brings in good metadata. Is this a simple thing to switch? Thanks
  • It is pretty simple and that'd mostly be me so it's been brought to the person's attention, I just have to get to it...
  • I just pushed an update to ASCE using EM.
Sign In or Register to comment.