zotero connector not correctly worked in pubmed,can you help me?

both the legacy and new version pubmed cann't displayed the right symbol (folder)
  • Reset your translators from the Advanced → Files and Folders pane of the Zotero preferences, and then do the same from the Advanced pane of the Zotero Connector preferences. Then reload PubMed and try again.
  • Thank u very much! I tried your method,but it still didn't work in most cases.

    In the new version PubMed,after performing a document retrieval, a page that includes multiple document lists, the Zotero Connector icon shows a blue white color, when I move the mouse onto the icon ,it display the text:'save to zotero(embedded metadata)',which is very different as before(the icon appears as a brown folder ),and the connector doesn't work. However, When I select a single article and click to enter another page,it does work normally.

    For the legacy pubmed, webpages containing multiple article lists and single articles cannot be used normally.
  • For the webpages containing multiple article lists, I tried reloading the webpage, press the 'esc' button ,but it wasn't the same as before, which always pop up a new dialog box to let you choose which document to add and which collection folder to put in
  • @shakemen: Can you provide example URLs?
  • https://pmlegacy.ncbi.nlm.nih.gov/pubmed/?cmd=historysearch&querykey=1

  • thank you!
  • edited May 26, 2020
    That first one is just a link to the front page of the old version, so I'm going to ignore that.

    The second one works fine for me. Can you provide a Debug ID from the Zotero Connector (not Zotero) for loading the PubMed page?

    Then, in Zotero, go to Tools → Developer → Run JavaScript, paste in the following code, run it, and let us know the result:

    return new Date( await Zotero.DB.valueQueryAsync("SELECT version FROM version WHERE schema='repository'") * 1000) + "\n" + new Date(await Zotero.DB.valueQueryAsync("SELECT version FROM version WHERE schema='lastcheck'") * 1000) + "\n" + Zotero.Translators.get("3d0231ce-fd4b-478c-b1d3-840389e5b68c").lastUpdated;
  • Just now, I tried Firefox again, it can be used normally.
    I will try another version of chrome right away to see if there is a problem with my chrome. Try not to waste your time!
    thank you!
  • After I replace the new version of chrome, it can be used normally!

    Thank you so much, thank you for your great work and kind heart!
    ☺ ↖(^ω^)↗
  • @dstillman: sorry to bother you again. the same mistake happens again in the recent twenty days. on page that includes multiple document lists, the Zotero Connector icon shows a blue white color, and no "Zotero Item Selector" dialog box pops up.
    However, When I select a single article and click to enter another page,it does work normally.
  • this time, I tried many methods ,even reinstalled the software and the zotero connector on another PC,but it still doesn't worked. thank you very much
  • Example URL?
  • @dstillman:
    allmost all the pages that includes multiple document can't worked normaly.


    when I selected and clicked the first article titled " Share Definition of major bleeding: Prognostic classification." to enter another page,it works normally.

    thank u !
  • Debug ID from zotero: D2004047230
    Debug ID from zotero connector:D1931127412
    thank u very much!

  • How are getting to this URL? Is this a saved search of some sort? If I just go to PubMed and search, I get a URL like https://pubmed.ncbi.nlm.nih.gov/?term=test that works fine.
  • @dstillman:
    thank you! yes, it likes some kind of a saved search.
    I use my e-mail to follow the latest papers on Pubmed.
    (the step is after I searched a "key word" in Pubmed, click the “Create alert" to another webpage,follow the steps, input my information,then I will received the latest papers at the specified time).
    I click the "view" icon in my email to Jump to the webpages above mentioned.
    20 days ago ,this approach and the corresponding web page can be used normally.
  • https://pubmed.ncbi.nlm.nih.gov/searches/5793873/?startDate=2020-08-09+07:57:12&endDate=2020-08-10+07:23:37&token=10Ae-DplhrucuH&sort=date
    I copy and paste the website above in a new address bar in chrome,it can go to the right page, maybe it's because my cookies contain my PubMed account login information
Sign In or Register to comment.