Zotero does not seem to be handling macro="access" accordingly

I have recently noticed that for the "journal article" type, when the variable/field "page" is being used, Zotero is not printing those itens on the bibliography list according to CSL specifications.

It seems to be working accordingly, for some styles, when "DOI" is filled, but when it is missing, Zotero should print URL and access date, which is not happening. The problem seem to be related to either "locators/page" or "DOI" variables.

OS: Windows Versão 10.0.18363 compilation 18363
Zotero version: 5.0.87

Steps to reproduce:

1. Start Zotero.
2. Click "Add new item".
3. Select "Journal article".
4. Fill in Title, Authors, Publication, Volume, Issue, Pages, Date, URL, Accessed.
5. Create a bibliography including the aforementioned item.

Zotero should display URL and Accessed parameters with the item printed bibliography, which is not happening.

Thanks,
André
  • Check the "Include URL" box in the styles tab in the Zotero preferences (this behavior has always been the same, btw.).
  • Thanks!
    I can't believe I've missed that. Probably lost the tick when I reinstalled Zotero recently, and I did not pay attention to that option after that.
  • Yeah, the default is unchecked.
Sign In or Register to comment.