Zotero not working with new Pubmed

I have the latest version of Zotero but the citations are being displayed incorrectly in Cite-while-write (first initial only) and the generated bibliography is completely incorrect (initials only, last name, importing the search url and not doi) using the Zotero Connector with chrome (latest version)
  • edited 17 days ago
    You're conflating saving from a given site (in this case PubMed) with citation output (which just uses whatever data is in Zotero). You shouldn't think of those as being related. You need to check your saved data for accuracy no matter what you do with it. Generating citations is just one of many things you can do.

    PubMed just made a change that broke saving from individual article pages, and we pushed out a fix earlier today. Your Zotero Connector should auto-update within 24 hours, or you can update manually by clicking Update Translators in the Advanced pane of the Zotero Connector preferences. If you're still having trouble after doing that, we'd want an example URL.
  • Actually, it is importing the metadata differently. The doi is being imported in with PubMed ID as extra data instead of as their own separate fields. I can show you a screen shot of an older Pubmed imported citation versus the newer one as well as the generated bibliography, which is taking the fields it is importing. I will see if the fix works. I always check my references, but I have to now redo all of the new imported ones, fixing the last names etc and finding dois. It is a tremendous amount of work.
  • Again, if you're having trouble, we'd need an example URL.
  • I just updated. This is what the bibliography looks like now:

    Am W, Jb P, Dm M, M C, Gj B. Jalview Version 2--a Multiple Sequence Alignment Editor and Analysis Workbench. Bioinformatics (Oxford, England) (2009) 25: doi:10.1093/bioinformatics/btp03

    So DOI is back but Zotero is importing the author names as the initial as the last name and the last name as the initial. No page numbers either as you can see.

    This is the url in PubMed: https://pubmed.ncbi.nlm.nih.gov/19151095/?from_term=waterhouse+jalview&from_pos=1: First author Andrew M Waterhouse, second author James B Proctor.
  • Again, the bibliography is not relevant — it's not helpful to discuss that when reporting problems with saving. What matters is what you see in the item pane in Zotero after saving. That's what you need to tell us.

    That page imports fine for me. Try updating translators manually from the Advanced pane of the Zotero preferences, and then do the same from the Zotero Connector preferences, and then reload the page and try again. If it's still not working properly, we'd want to see a Debug ID from the Zotero Connector for loading the page and saving.
  • That fixed it! Thanks a ton. Tracy
Sign In or Register to comment.