Unknown error in Word document

Dear all,
I'm working on a word document and I encountered an error that I couldn't resolve. It took me a lot of time to fix, but none of proposed solutions could fix it.
Description: adding each new reference results in an error message. I can add the new reference, but the font is different and does not wholly integrate into the document, like before. Unfortunately I don't know the error code.
  • You will have to follow the debugging broken documents steps or provide us with more information about your error, e.g. what happens at teach debugging step.
  • Thanks for your prompt reply.
    It's the famous error:
    C:\Program Files (x86)\Zotero Standalone\zotero.exe
    Zotero experienced an error updating your document.
    I tried proposed solutions, but nothing worked out.
  • What happens in a new document? Could you submit a Report ID?
  • the error ID is: 1906180712
  • This error can certainly be fixed by the debugging broken documents steps. You either have tracked changes that you have not accepted or there's a corrupt part of the text that can be isolated with step 10.
  • Thanks for your help.
    Between proposed solutions, I didn't understand how the 9th solution would help.
    My problem is that there are many corrupt parts in the document. I didn't pay attention to the problem when it occurred for the first time and continued to write down. Now, I cannot figure them out, even for separated part of the document. I took only 3 pages, out of 30 already written pages. But even in this 3 pages, I couldn't find out where is/are broken citations.
    Thanks a lot in advance for your valuable help. As I've only several days to finalize my writing and already spent several days to resolve this problem.
  • I tried to check my Error ID again, it gives me a new one: 254597668
  • I'm sorry, but there is no automatic way to fix a broken document. You have to follow step 10 of the debugging instructions. Note that on a 32 page document it only takes 5 steps to cut it down to 1 page. Step 10 is designed to be the fastest way to find problematic parts of the document and it really shouldn't take many steps to identify the fault and correct it, but you will have to go through with the debugging manually.
  • I understand and there is no problem to do all different steps: I already got through them.
    The problems are:
    On the one hand there are many broken citations in the document. I tried to delete them one by one. But then, I've correct citations turning into broken!!! So the more I identify and delete, the more I'll see breaking citations.
    I'm sorry to bothering you too much, but sincerely after having tried all different solutions, I don't see how I can solve the problem.
  • How are you determining that a particular citation is broken?

    Also, part of the point of those steps, as it explains, is to isolate a broken citation so that you can send us a small excerpt of the document that demonstrates the problem. If you can do so, we might be able to tell you more.
  • A broken citation turns automatically to a different font and size. Furthermore, after a broken citation the document remains connected to Zotero.
    I'll send you an excerpt to see (to support@zotero.org).
    Once more, thanks a lot for your support.
  • I created a new Word document and added citations to it manually. Initially, it worked. But now, I've a new error message: "Erreur d'Intégration de Zotero".
    The report ID is: 1747995146
    (I didn't use your troubleshoot)
  • @hajit Did you save this new document in OneDrive? That might cause issues. If not, could you send it to support@zotero.org too?
  • Yes, It was in OneDrive. Sorry.
    I changed the folder and apparently, Zotero works fine now.
  • Dear support,
    Following our exchanges, unfortunately, I've again got the same problem.
    The ID is however different: 7155478
    Looking forward to hearing from you,
  • That is the same error you had in your original report. And so the suggested solution is also the same, unless you see this error in a new document.
  • I was looking for your update, as none of the proposed solutions worked!!
    I sent you an excerpt yesterday and am waiting to know how to resolve this issue.
    In the meanwhile, I created another document to be able to continue, but unfortunately, even this second document is affected by the issue, that's why I sent you this new Report ID for it.
    So sorry of bothering you several times, but I already spent several days to resolve the problem and couldn't. It's my thesis dissertation and I've only several days to finalize it. That's why I wrote to you for help.
  • I've just tested with your excerpt and didn't have any problems refreshing the document. There was a stray "{Citation}" at the end of the excerpt that needed removing. And while refreshing the dialog came up for a few modified citations, which when clicked through, the document updated fine.

    There appears to be some spacing issues with some citations, which are fixed by removing extra spacing.
  • What is the full version number of Word that you are running?
  • Version 1902 (build 11328.20392 Office "Démarrer en un clic")
    ID de produit : 00202-52328-55209-AA960
  • I uninstalled Zotero and Word Plugin and reinstalled them, the problem is occurring again.
    Repport ID: 662070249
  • Reinstalling Zotero or the Word Plugin certainly won't help. You could try updating your Word version, but that is also unlikely to be a remedy. You will have to identify the sections of text that are causing issues in your document yourself, that is the only reliable way to fix the errors you are seeing.
  • Thanks for your prompt reply.
    I'll send you via email, my new Word file with error.
    There is nothing that might causes the problem. Only a text and a citation comes after it. It's several years that I'm using Zotero. Have never encountered such an unusal issue! :(
  • edited May 20, 2020
    The document you sent in is certainly not right, although it updates fine for me with Word 365 2004 (12730.20270). Somehow it has the Zotero plugin embedded in it and added multiple additional Zotero tabs for the ribbon. How did you create this document?

    You should go to Word startup folder and remove any files with Zotero in the name. It might help to temporarily move away any other files from there too, or disable the add-ins in Word, to have minimal interference from other plugins. You should also locate the Normal.dotm template file and move it somewhere else at least temporarily (like onto your Desktop). After that reinstall the Zotero plugin from Zotero Preferences -> Cite -> Word Processors. Opening any Word document either with or without Zotero citations should never add additional Zotero ribbon tabs.

    Otherwise, the second citation in that document seems to not have been properly updated, but I am not experiencing any issues adding citations to the document you sent us.

    I also highly suggest updating Word to the newest version, since the one you're running is quite out of date.
  • I'm very grateful for your help.
    Maybe it's because I uninstalled the Zotero plugin and reinstalled it. I had the same problem, but now it's disappeared and I've only one Zotero Plugin.
    The solution you proposed works for a new Word document, but not in my previous works.
    After having passed hours and hours... I give up!
    I'll try LibreOffice :(
  • You won't be able to update the Zotero citations in your existing documents with LibreOffice, since the citation formats between the two are not compatible. You can transfer documents between LibreOffice and Word, but that requires the Word Zotero integration to function properly.

    Once again, you have not really talked about whether you have properly tried Step 10 of debugging instructions and what was the result. Did you ever trim down your existing document to something like a single paragraph and have the integration begin working? Have you tried doing that after copying the document contents into a new document first?
  • Of course I did!
    As I explained earlier, now this issue appears even in a new document without anything on it. only one word and a citation, it works, once I add the second citation the error appears and Zotero proposes me to go to the debugging page
  • The solution you proposed works for a new Word document, but not in my previous works.
    You are saying conflicting things, which makes it hard to understand what works and what doesn't, and when it works, and when it does not, and thus give you relevant advice.
    now this issue appears even in a new document without anything on it. only one word and a citation, it works, once I add the second citation the error appears and Zotero proposes me to go to the debugging page
    Is this still the case? Did you perform the thing suggested in my earlier post https://forums.zotero.org/discussion/comment/356543/#Comment_356543? Did anything change after doing that? If you can insert and edit citations fine in new documents now, you should attempt step 10 of the debugging instructions on your thesis.
Sign In or Register to comment.