TypeError: params.join is not a function

Every time I try to start Zotero I get this error message:

"Datenbank-Upgrade-Fehler (Roughly translates to: Database-Upgrade-Error)

TypeError: params.join is not a function
From previous event:

I have tried to reinstall Zotero, I even installed the beta version. This message always comes up and I only have the options to a) quit or b) check for updates which results in the fact that there are no updates so in the end I can only quit there as well.
Hopefully this can be fixed somehow as I really need to access my database soon.
I am running macOS 10.15.3
  • @lewoe: Actually, can you install the latest Zotero beta and provide a startup Debug ID for that instead? It should log a better error that might help us figuring out what's going on with your database.
  • Thank you for the quick reply. I can't click the 'submit' button as the error message pops up first and blocks out all other actions. The debug window does show some data but I don't really know what you need. Is there a way to post a screenshot in here? I tried both the -ZoteroDebug and the -jsconsole commands
  • edited May 12, 2020
    Might not be possible, but did you try switching windows with Cmd-` (backtick, above Tab)?

    If that doesn't work, you can upload a screenshot somewhere (e.g., Dropbox) and post a link here or send to support@zotero.org with a link to this thread.
  • Those are from 5.0.86. Did you see my follow-up message asking for this from the beta?
  • Sorry I thought that was the beta... Here is what I get now:
  • OK, yeah, that's what I thought. Your database is corrupted, which generally happens from having your Zotero data directory in a cloud storage folder or network drive. (Are you storing it in pCloud?) If that's the case, you should move it back to the default location.

    You can try to fix the damage with the DB Repair Tool. If that doesn't work, and your data is all online, you can just move the zotero.sqlite file out of the way (and keep temporarily as a backup) with Zotero closed and then reopen Zotero and sync to pull down your library.
  • Thank you very much! It seems to be working again.
    I tried deleting the sqlite file and syncing my library with my Zotero account and now I can access everything again.

    If you say storing my library in a cloud is not a good idea, is there a way to automatically backup my files there? Or is doing it manually the only way besides applications like Carbon Copy Cloner etc.?
  • Yes, you absolutely shouldn't store your data directory in a cloud storage folder. This isn't specific to Zotero — the same goes for any database-backed program.

    Out of curiosity, did the folder path contain "pCloud" in it? We warn when the path contains "Dropbox", "Google Drive", or "OneDrive", but I'm not sure if there's a standard path for pCloud.

    Do you not use Time Machine to back up your entire computer? That's the easiest thing to do. There's nothing special about Zotero. You should have a regular, automated, incremental backup of your entire disk.
  • Alright thank you again for helping me out here with my ignorance!

    I'm pretty sure that 'pcloud Drive' was part of the folder path. However I do not remember wether there was no warning or I ignored it.

    I have had some problems with Time Machine so I thought it best to backup these important files in a cloud.
  • No, as I say, we don't warn for pCloud currently, just the big three providers, but it's something we could add. We've just had other reports of people using pCloud from custom directories, so I wasn't sure if having a directory that actually includes the word "pCloud" is common.
Sign In or Register to comment.