Found a workaround for "Zotero experienced an error updating your document." in OneDrive

Hi


I was getting the "Zotero experienced an error updating your document." error when trying to add citations in a Word doc saved in my OneDrive folder (the doc otherwise worked fine when saved in other folders).

I have found that it seems to only affect docs with spaces in their filenames, e.g. "Breguetv11" works but "Breguet v11" does not. Renaming afflicted files (i.e. deleting any spaces) makes them work again.

I hope that this works for anybody else who has had this issue.


I reported this using this debug thingy- D1352619682. It'd be nice if it could be fixed, but if it can't then perhaps the workaround added to the "https://www.zotero.org/support/kb/debugging_broken_documents" page?
  • Thanks. We've been unsuccessfully trying to track down what's causing this for a while. We'll look at fixing this soon. You can follow https://github.com/zotero/zotero-word-for-windows-integration/issues/50, but we'll post on this thread too once we have a fix available.
  • Great stuff, glad I could help a bit (Zotero helps me a lot)!
  • @hoverdonkey I'm trying to reproduce this locally and cannot get it to break. Would you mind saving the document in a location on OneDrive where you know it breaks and producing a Debug ID from Zotero?

    1. In the Zotero Help menu, go to Debug Output Logging and select Enable.
    2. Attempt to insert a Zotero citation in the Word document stored in OneDrive where it breaks
    3. Before doing anything else, return to Zotero Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • Hi

    I cannot break it now either! I had kept several versions of the document that were not working previously (before I discover the space fix) but I have tried some of these and all are fine now.

    Something must have changed on my system - whether that is Word, OneDrive, Zotero or something else altogether I do not know. I notice that my Zotero install is now on version 5.0.87 - the changelog indicates there have been two updates since I posted my message on May 4 (but I cannot see a specific reference to a fix for this
    issue).

  • We have not changed anything related to Word integration since your post, but I just got around to trying to fix it and found I couldn't reproduce it. Perhaps a fix came on Word's side. We've done an initial fix of OneDrive breakage a couple of years ago but have been getting reports of this on-and-off and I could never reproduce the error. I though we had this nailed down with your report, but alas, not so sure anymore. I'll keep that issue open for now and if we don't see any more user reports for OneDrive editing we'll consider it fixed.

    Thanks for the help!
  • Many thanks for looking at it @adomasven. Let's hope it has gone away for good!
  • I was getting the error today, and solved it by removing the spaces from the filename. Adding the spaces back brought the error message back. Spaces are a problem, but not & or ' or α, so it's evidently not just a URLEncode issue.
  • Aaaand, I just updated Word from 16.13001.20338 to 16.13001.20498 and I can no longer reproduce the error. Everything's working fine, even with spaces in the filename.
  • This appears to be a recurring bug that I am beginning to suspect Microsoft keeps on patching and reverting, either intentionally or by accident. Every time I try to reproduce it it magically disappears, possibly due to ever-updating Word versions.
  • Now the error is back, so that eliminates the hypothesis that it's a matter of Word versions.
    And the problem is not just space in the filename, but also ^[]{}`.
    So after some trial and erroring, I think I've identified the culprit: %
    In the file's URI that begins https://d.docs.live.net/ Space is encoded as %20
    [ as %5b
    ] as %5d
    ^ as %5e
    ` as %60
    { as %7b
    } as %7d
    ^ as %5e means there are also problems with the following symbols (at least) in the filename:
    # is converted to ^N
    % is converted to ^1
    & is converted to ^0
    + is converted to ^M
    , is converted to ^J
    (^is converted to ^L)
    ~ is converted to ^F

  • @kmpenner Have you identified in what cases " " does not produce an error though? That's my main issue in troubleshooting this - I cannot find a reliable way to reproduce the error, and/or to make it go away.
Sign In or Register to comment.