Identifier does not recognize correct DOI

Dear all,

I recently tried to add the following DOI:10.3000/1977088X.C_2012.326.deu to my library. Unfortunately the identifier does not recognize this DOI and i double checked this DOI in the DOI database and was surprised that the DOI actually works.

Why does the identifier not accept this DOI?

Thank you for your feedback, tipps & tricks in advance which I will much appreciate.


  • Zotero is only able to import metadata from DOIs where the registration agency provides metadata and machine-readable access to that. That's the case for most DOIs, but some agencies -- here the EU publication office -- don't so there's nothing Zotero can do. The redirect by is at a much more basic level
  • Is this the same issue for something like ? Clicking this takes me to the expected page, but when I put this in crossref it claims it is "unreasonable". Am I missing something?
  • Ok, so my understanding is that this is not a "Crossref DOI", and so doesn't have the info it needs. Not all DOIs are alike it now appears...
  • Someone else probably knows, but it's not clear to me how this is a valid DOI at all. A DOI begins with "10.":
    The DOI prefix shall be composed of a directory indicator followed by a registrant code. These two components shall be separated by a full stop (period).
  • Maybe it's no longer valid for new types but was once? Anyway, it's a genuine, decades old academic journal that is still publishing new issues, the articles are still being given new DOIs, and the new articles are (still) resolving via I am intrigued so if anyone does know how it is valid, please tell!
  • That’s not a DOI but an HDL handle. A DOI is subset of the handle system, but the system is much broader. I’m surprised that the URL works. You should not enter this as a DOI (it’s not). Instead, enter the URL at the top of the page into the URL field:
  • I’m surprised that the URL works. is essentially just a (fancy) proxy in front of the handle system -- you can pass any handle ID through and it will resolve just like you can pass any DOI to and it will resolve.

    Obviously the fact that you can doesn't mean that you should, and the fact that a library, of all places, would effectively "spoof" a DOI is a bit sad.
  • Yeah, that’s weird.
  • edited September 24, 2020
    network proxy problem in my case, fixed.

    "i can confirm that it's not the meta data error, i tried two dois (10.1002/tpg2.20028, 10.1038/ncomms15407) that were added to my zotero library through doi search before. The new zotero can not recognize the doi, PMID is also not read by zotero now. "
  • Hi,

    I'm experiencing an error with DOIs like this one: 10.35562/arabesques.1478.
    Any idea why Zotero can't retrieve the metadata available on Crossref (

    Thanks for any help you could provide !
  • edited April 21, 2021
    This looks like a problem on their (i.e. CrossRef's) end, likely temporary. We're using another API which just doesn't return anything for that DOI (and seems to be super sluggish this morning in general)
  • Update: looks like this is now working again. CrossRef has been having some trouble with that particular DOI recently
  • Right! It' works now. Sorry for bothering you with some temporary trouble unrelated to you.

    For the sake of curiosty, what Crossref API do you use?
  • We use content negotiation, so we only have to make a single request for any DOI rather than cycling through multiple APIs (CrossRef, Datacite, mEdra, etc.)
Sign In or Register to comment.