5.0.85 Sync Error: "It may have been saved with a newer version of Zotero."

  • Same error occured here. Error report: 1861011332.
    Restarting Zotero and/or notebook does not help. The same error appears consistently. The error report always refers to DQZ5AJ2F. However, this item is not found when pasting into Zotero (locally and online) and no such directory exists in Zotero storage locally.
    The error might be connected to a database error message from Zotero a few days ago (April 19). Zotero then asked to be restarted and did not report any problems on restart.
    Could you please help ?
    Thank you !
  • edited April 23, 2020
    Invalid data error for collection DQZ5AJ2F in [group]: Unknown collection property 'dateAdded'" {file: "chrome://zotero/content/xpcom/sync/syncLocal.js" line: 1059}]
    This is a different underlying error, referring to a collection, not an item, which is why you can't find it in a search.

    Can you provide a Debug ID (different from a Report ID) for a sync attempt that triggers this?
  • Dear Dan: instant response at 2:45 eastern time. Wow !
    The Debug ID is D1116281938.
  • Can you go to Tools → Developer → Run JavaScript, paste this in, run it, and let me know the result?

    return await Zotero.DB.valueQueryAsync("SELECT data FROM syncCache WHERE libraryID=? AND key=? AND version=? AND syncObjectTypeID IN (SELECT syncObjectTypeID FROM syncObjectTypes WHERE name=?)", [250257, 'DQZ5AJ2F', 0, 'collection'])

    You can x out the collection name and anything else you want.
  • Only got
    ===>false<=== (boolean)
    Should I run the sync again ?
  • OK, this should be fixed in the latest Zotero beta. You can install that, sync, and revert to the release version.

    Alternatively, you can probably just run this to see the collection in question and change the name to match the remote name (which is what you'll get after syncing):

    return await Zotero.DB.valueQueryAsync("SELECT collectionName FROM collections WHERE libraryID=? AND key=?", [250257, 'DQZ5AJ2F'])
  • Beta did the trick. Back to 5.0.85 is now also ok. Problem solved.
    Thank you for the great and immediate help !
Sign In or Register to comment.