Can't install LibreOffice plugin from Snap package

This discussion was created from comments split from: [Solved] LibreOffice can not connect to Zotero.
  • I'm having a similar problem. I got a new computer Friday. It had Libre pre-installed and I installed Zotero yesterday. In tools>add-ons integration is enabled. In preferences>cite if I click Install Libre add on there is just a blank list. If I try manual installation the directory it sends me to (snap/zotero-snap/14) is completely empty. I don't have a ~./zotero folder and can't find extensions.json anywhere otherwise I would try deleting it. Since it is a brand new zotero install from yesterday re-installing again doesn't seem like it will work. Is there somewhere I can just download the integration.oxt file? I'm not sure what else to try.
  • Sorry, we can only help with the official Zotero tarball, not the third-party Snap package.

    The package maintainer, @extraymond, may be able to help.
  • It's okay, I ended up figuring it out.
  • Having the same problem with Zotero snap integration into LibreOffice, I would like to know how you solved the problem. Thanks.
  • Same here, my zotero plugin stopped working after the upgrade to libreoffice-
    I can install the zotero plugin via Snap Package, but nothing appears in LibreOffice. Last time it worked to uninstall and reinstall Libreoffice and Zotero.
  • I solved my issue by replacing the snap package of LO with the version from apt (6.0.7-0ubuntu0.18.04.10). Seems like libreoffice- is not able to access zotero out of his sandbox...
Sign In or Register to comment.