ID: 271491053

pas de bibliothèque
  • [JavaScript Error: "Error(s) encountered during statement execution: unable to open database file [QUERY: DROP TABLE IF EXISTS tmpSearchResults_ZS59Jd4h] [PARAMS: ] [ERROR: unable to open database file]" {file: "chrome://zotero/content/xpcom/db.js" line: 664}]
    Zotero isn't able to open your database. This could be due to filesystem permissions or security software interfering, or your database could be corrupted (though that would normally be a different error message).

    Do you have your Zotero data directory in the default location, or have you moved it elsewhere (e.g., a cloud storage folder)?

    If it's in the default location, can you provide a Debug ID for Zotero startup?
  • He is here C:\Program Files (x86)\Zotero

    This is debug report ID D1944518936.
    Zotero show "error loading items list"

  • edited April 8, 2020
    That's your program directory. The question was where your data directory is, but it looks like it's in the default location (C:\Users\[username]\Zotero), so that's fine.

    I think this would happen if Zotero wasn't able to create a temporary file in the data directory, so you'll need to check filesystem permissions and security software as I say above.
  • I succeeded after deleting my data directory. And then I synchronized with my zotero online account to find my data.

  • Just to note, deleting the data directory definitely isn't necessary, but glad to hear it worked for you. If other people are experiencing this, I'd strongly recommend trying to figure out what on the system is interfering rather than deleting the data directory.
  • I tried to delete my data directory. At first it worked. But when I restart zotero again, the same error occurs. So this didn't actually solve the problem for me.
  • Right, don't delete the data directory — it's not a real fix for this. Something on your system is interfering, and you'll need to figure out what that is.

    Are you running any security software?

    When you close Zotero, what are the names of all the files in the root of your Zotero data directory?
Sign In or Register to comment.