zotero link to Onenote

I've pasted a link to a Onenote page into a Zotero note, the link was created, but I'm getting a error.

"Microsoft OneNote - We couldn't open that location. It might not exist or you might not have permission to open it."

I pasted the same link from OneNote into MS Word and I get the following message. "Microsoft Office has identified a potential security concern." and it ask if I want to continue yes/no. If I say yes, then the link works.

I've been trying to turn off this level of security, but can't find where. Things I've tried are:
1) refreshed the credentials for MS Office
2) insured that the directory structure of OneNote is shared by EVERYONE.
3) Set User Account Control off.
4) Under Security and Maintenance - Change Security and Maintenance Settings - I turned off User account Control and Internet security settings.
5) turned off Windows Defender Firewall.

Any advice?
  • I mean…don't do those things. If this doesn't work, it doesn't work — you shouldn't turn off every security feature on your computer to try to get it to.

    I don't have OneNote to test this, so I don't know why that wouldn't be working for you.
  • First, as dstillman says, you should undo all of those changes. They won't help, and you will seriously put your computer at risk.

    Then, a couple of questions:
    1) Does the link you are copying start with onenote:// or https://onedrive.live.com/view.aspx??
    2) Are you using OneNote 2016 or the Windows Store version of Onenote?
    3) What version of Windows or macOS are you using?
    4) If you paste the link into your browser's URL bar, can you open it?
  • edited April 6, 2020
    Yes, thx for your concern. It is a test PC and yes, the features would be turned on as soon as I discovered how to control the situation. In fact, after consideration the particular windows/onenote feature which is raising the error/warning I wouldn't want to undo. Which made me think. Why does MS Word handle the security feature and by allowing me to answer yes/no to proceed into Onenote via the link, and Zotero is not able to complete the link into OneNote? This is the lingering question.

    > The link starts with onenote://
    > It is Office 2013 Home and Office addition (installed via CD)
    > It is Windows 10 with all updates
    > From MS Word and Chrome the result is the same if I paste the link. I get the warning and an optional yes/no to proceed. Additionally from Chrome I get a message even before that one with a yes/no to proceed.

    The concern about security is well taken, and I wouldn't want to disable that feature even after I spent a compulsive 4 hours trying to figure out how to control it. It seems to me that Zotero is not handling communication with that Windows/Onenote security feature and just terminates the link instead of communicating properly with the security feature and letting the end-user decide via a proper handshake between Zotero and Windows.
  • Okay, so this is not a Zotero issue at all, but one to do with permissions for opening your OneNote notebook generally.

    Where do you have your OneNote notebook saved?

    You should search or post on support forums dedicated to Office/OneNote, as again, this isn't a Zotero issue, but one with OneNote. Here are some threads with potential solutions I found with a quick Google search of your error message:

    (As an alternative to troubleshooting this, you could just upgrade to the Windows Store version of OneNote, which is free, or to OneNote 2016, which might have fixed a bug causing this.)
  • Thx for the links. I'll check them and and get back to the forum if there is a fix. I understand how this could easily NOT be a Zotero problem, but at this juncture I'm not convinced that Zotero is handling the handshake properly, while Chrome and MS Word are.

    Thx for the quick reply.
  • There is no "handshake". Zotero is just opening onenote:// link using your system protocol just like MS Word or Chrome. As you say, it's not working in any of those programs. Something is wrong with the onenote:// protocol on your system. That has nothing to do whatsoever with Zotero.
  • I'll defer to your expertise that this is not a Zotero problem, and this is likely true. This issue, I'm sure, is a low priority. And thx again for the links. I'll look them over.

    Just for clarity sake then...

    The link protocol IS working for Chrome and MS Word, and NOT for Zotero. The warning window giving the user a yes/no option to proceed is a normal windows security window I've seen before. Where it comes from, that is, what Windows/app option, that enables this security feature is unknown to me. And that is why I started down the path of disabling all the security features I could to locate the source, and then decide next steps. Since I did not find the controlling Windows/app feature I gave up. While understanding that it would be unwise to disable the feature in any respect.

    IMHO, Zotero should provide the user the same option of a yes/no reply to proceed or not. It appears (to this novice) that Zortero is not communicating properly defined by the 'protocol' to this windows native security feature, hence the link process simply stops with an error. If Chrome functions properly through the security protocol/process/handshake then shouldn't Zortero?

    As to your question of where Onenote is.. It is on another PC in the private network. I tested a local copy of Onenote and the same error occurs with Zotero (which is local) and not Chrome (which is also local).
  • edited April 7, 2020
    Opening a OneNote link should not prompt the security message at all. Something is wrong with your installation of OneNote/Office.

    Like I have said several times, this isn’t a Zotero issue. Zotero can’t “provide the option”. It simply tells your system to open the link using the default program. Any behavior after that is your systems’s.

    You could check your default programs list to see if onenote:// links are being opened as administrator (they shouldn’t be). Beyond that, I don’t have any other ideas for helping you. I suggest you contact a onenote or office forum or an IT professional.
  • From Microsoft: The following seems to help some folks, and makes sense, but didn't work for me.


    We can disable the security warning by changing the registry key. Here are the steps:
    1. Press Win + R to open the Run window, then type regedit and click OK to open the Registry Editor.
    2. In the Registry Editor, locate the following subkey:
    3. On the menu bar, click Edit > New > Key, type Security and press Enter.
    4. Right click Security, then click New > DWORD (32-bit) Value, type DisableHyperlinkWarning and press Enter.
    5. Double click the above value, select Decimal and change the Value data to 1, then click OK.
    6. Then the hyperlink warnings will be disabled in Office 2016.

    Kindly let me know when you have tried the above steps.
  • After uninstalling Office and then reinstalling the link process now works for OneNote!

    Thx for pushing me to focus on Office/Onenote.
  • Glad to see you got it working.
Sign In or Register to comment.