About new Export to Zotero feature in Mendeley Desktop v1.19.6-dev4

In this release notes https://www.mendeley.com/release-notes/v1_19_6-dev4 they mention:
changed the way you export from Mendeley to Zotero and import from Zotero to Mendeley to use Zotero’s API

Has anybody tried this?
  • edited May 19, 2020
    I just updated to the 1.19.6. But seems still cannot import from Zotero side. The same error message of "encrypted database" still showed up.

    All right, I played with the 1.19.6 Mendeley a bit more. In Tools >> Options >> Zotero, now you can find an export option. I've tried several times, got the following error message.

    ZoteroAPI unexpected response. Error transferring https://api.zotero.org/users/ (my user ID)/items/PFFJUMSN/file - server replied: Bad Request. The file causing the error: C:/Users/(my Windows user name)/AppData/Local/Mendeley Ltd./Mendeley Desktop/ Downloaded/(a document's title, different each time).pdf

    I don't think this is caused by a particular document as it reported a different title each time I tried the export function.
  • When you get it to work, can you tell us whether PDF annotations are available after the export to Zotero?
  • I've tried several times, got the following error message.
    Yeah, it's broken. When I tested it, it gave me that error message for an item with a missing file — which for some reason it was apparently still trying to upload. I'd guess that many/most people who try to use this will get that error.

    Unlike Zotero's Mendeley importer (and their previous Zotero importer), it also doesn't sync existing items, at least on failure — it will just keep creating duplicate collections and items in the target library on every attempt.

    I didn't really look at it beyond that, so I don't know if they're uploading PDFs with embedded annotations, but due to the file upload issue it's not really in a usable state at this point.

    (And, obviously, they added this while still encrypting their local database, which kind of misses the point.)
  • It worked when I set the mendeley, but the reslut is quite bad.

    1, there are always some errors when export the reference from mendeley to zotero.
    2, each time when export from mendely, zotero always creat the whole copy from mendeley.
    3, same with import from zotero into mendeley.

    The sync is not work at this time acoddring to 2 and 3, and even the copy work between mendeley and zotero is not work well(1).
  • each time when export from mendely, zotero always creat the whole copy from mendeley.
    No, Zotero has nothing to do with this. It's Mendeley doing that — as I say above, it just creates a new version each time. It's not really a usable feature at this time, which is why we're still recommending our importer with an old version of Mendeley.
Sign In or Register to comment.