Reference imported as webpage in new PubMed

This discussion was created from comments split from: Connector not working with Clipboard in New PubMed.
  • When using the Zotero plugin to copy a reference from PubMed into Zotero desktop (Mac) in the new version of PubMed, the reference is imported as a webpage and is missing most of the bibliographic information. Resulting in this:

    “Cluster of Severe Acute Respiratory Syndrome Cases Among Protected Health-Care Workers--Toronto, Canada, April 2003 - PubMed.” n.d. Accessed March 28, 2020.,+April+2003&from_pos=1.

    Rather than this (obtained using the legacy PubMed interface:
    Centers for Disease Control and Prevention (CDC). 2003. “Cluster of Severe Acute Respiratory Syndrome Cases among Protected Health-Care Workers--Toronto, Canada, April 2003.” MMWR. Morbidity and Mortality Weekly Report 52 (19): 433–36. PMID: 12807083.
  • @dmilton: That page is saving fine for me. See Troubleshooting Translator Errors. The only issue on the new PubMed should be saving from the search result page.
  • My plugin is the version 5.0.61, which appears to be the latest. But, it only recognizes that page as a generic webpage. However, this seems to be something specific to MMWR not all journal articles. So, for example, this one downloads correctly from the PubMed:

    Ng, Kangqi, Beng Hoong Poon, Troy Hai Kiat Puar, Jessica Li Shan Quah, Wann Jia Loh, Yu Jun Wong, Thean Yen Tan, and Jagadesan Raghuram. 2020. “COVID-19 and the Risk to Health Care Workers: A Case Report.” Annals of Internal Medicine, March. PMCID: PMC7081171.
  • You'll need to follow all the steps on the troubleshooting page.
  • The only thing there that would possibly work is disabling all plugins. I don't have time for that now. Under deadlines to respond to the pandemic.
  • edited March 28, 2020
    1) There are various other steps on there (e.g., resetting translators), and you wouldn't have any way of knowing if they worked without trying them.

    2) The page includes a request for specific information we'd need to debug it further if you've tried all the other steps (though it's very unlikely that the steps wouldn't fix the problem if the page is working for others).

    If you don't have time to follow the steps in full, that's fine — I'm just telling you that this works in general, and we wouldn't be able to troubleshoot it without more info. In a pinch, you can always add PubMed items by pasting the PMID into Add Item by Identifier.
  • Excellent -- reset translators (also did update translators in plugin) worked! Thanks for the specific pointer. Now back to dealing with politically motivated misinformation from WHO.
Sign In or Register to comment.