LibreOffice integration manual installation on Mac OS X

I would like to report a problem I had with Zotero-LibreOffice integration on Mac. I solved it after some hours of investigation and failed attempts and I would like to share my solution with anybody who run into same trouble (also as reminder for me when the next update crashes integration again).

I recently updated LibreOffice to version 6.4.2.2 on MacOS X 10.10.5. Yosemite and unfortunately the Zotero Extention that integrates Zotero into LibreOffice got lost. In Zotero the LibreOffice Integration Add-On is enabled and it also did not help to disable, restart and than enable again. Oracle JDK 1.8.0_241 is enabled in LibreOffice. The Zotero extention does not appear in the Extention Manager in LibreOffice.

I run the system with an administrative account and an user account with lesser priviliges. Normaly I install applications from the user account beeing prompted for administrative credentials. When I logged in directly with the administrative account and started Zotero it recognized the new LibreOffice installation and installed the Add-On. LibreOffice meanwhile open crashed but after restart the Extention Manager showed the Zotero Integration. Back in my normal user account I started again Zotero and LibreOffice but there was still no Zotero Integration in the LibreOffice Extention Manager.

Finally I tried to follow the instructions for manual installation of LibreOffice integration here: https://www.zotero.org/support/word_processor_plugin_manual_installation
unfortunataly that instruction does not work on Mac OS. The path to the oxt file is "hidden" in an .app file in the "Programme" (I think in English "Aplications") folder of Mac OS. You need to open that package to go further into the folder/file-tree of the program package. That is possible in the Mac OS file browser Finder (right click on the zotero.app and select "show package content") but not from within the LibreOffice extention manager as proposed in the instruction. you end up at the zotero.app file and get an error message when trying to open it from within the extention manager.

SOLUTION:
It took me some time to try the most obvious. Search for the oxt-file in Finder (Zotero.app/Contents/Resources/Extentions/zoteroOpenOfficeIntegration@zotero.org/install). Doubleclick it and it prompts for installation into LibreOffice.
Note: You need to manually open the Zotero.app "package" with right click. Search via Spotlight won't find the file inside the package.

Maybe someone with write priviliges to the Zotero Documentation can add this simple but important hint for Mac OS users?

And maybe some of the developers might look into the case of MacOS configurations with two user account? I still do not understand why this happend because the extention is in the "program" folder that is used by all user accounts.

I hope my post will help some Zotero users who run into same troubles.
  • edited 4 days ago
    Back in my normal user account I started again Zotero and LibreOffice but there was still no Zotero Integration in the LibreOffice Extention Manager.
    That's expected. The LO profile is within your home directory, so if you installed the extension from another account it's not going to show up. If it doesn't install automatically in a given account (e.g., because it was previously installed and then removed), all you should need to do is reinstall it from the Cite pane of the Zotero preferences.

    We'll clarify the Mac manual installation instructions — sorry about that.
Sign In or Register to comment.