Can't move collection from My Library to new group

Error: 1867950568
Within my library, have a collection called "Jaguar and other cats." It has 20 sub-collections, one of which is called "Ecoregions." I created a new group called Shazam and had never previously tried to drag in "Jaguar" into Shazam, i.e. Shazam was virgin. When I did drag "Jaguar" into Shazam, the collection "Jaguar" does not appear listed in the left-hand pane in the Shazam library. Instead, I see 4 of the 20 sub-collections within "Jaguar," including the sub-collection called "Ecoregions." To reiterate, the collection itself does not appear in the left-hand pane, only 4 or the 20 sub-collections.

It's as though Zotero has plucked the 4 sub-collections our of the "Jaguar" collection, and only copied them to the Shazam directory.

I have repeated this process several times, each time deleting the previous group, creating a new group with a new name, and trying to drag in Jaguar." No luck.
  • Can you provide a Debug ID (different from a Report ID) for the drag?
  • Sorry, I didn't have debug enabled. It is now. I assume I now should try to repeat the process to generate an error code?

    Also, since I posted I deleted the group directory, created a new group directory, and again dragged the "Jaguar" collection with the 20 sub-collections. I did this before I knew to enable debugging. This time all the documents appears in the new group directory (called Ramadama), but none of the sub-collections structured was preserved. Before I dragged this time, I made a tag for all the items in each sub-collection, so I could search by tags and then recreate the sub-collection structure. A pain for sure. Any ideas before I try again with debug turned on?

    BTW, I can't believe you responded so quickly late at night. I did see someone else in the forum commenting on your amazingly rapid response!
    Rob
  • I assume I now should try to repeat the process to generate an error code?
    Yes. You don't need to do anything else, but we can't tell you more without that.
  • @robpeters: To be clear, there's a specific process to follow, explained on the page I linked to above. Debug logging isn't something you leave enabled. You need to turn it on, reproduce the problem, and then submit it immediately.
  • I finally gave up trying to drag from My Library a collection and all its subcollections to the Group "Ramadama" because the subcollections never appeared in the group. Instead, I made a new collection in Ramadama, and then dragged each subcollection from the parent collection in My Library. This sort of worked. Some subcollections would appear more or less immediately after being dragged. But others, despite waiting for 15 minutes or so, never appeared in Ramadama, despite synching, exiting and restarting Zotero, etc. Eventually, after as many as 6 tries the drag worked.

    Here is the error code for one of the attempts that didn't work. D415008405

    So, I've worked around my problem, but am still curious why a) the subcollections didn't show up when the parent was dragged to the group directory and b) why some subcollections quickly showed up in the group parent directory after being dragged there, but some required multiple drag attempts before it "took."

  • Here is the error code for one of the attempts that didn't work. D415008405
    The copying was still going on when you submitted that. There's no feedback currently, but it was still going.
  • Wait, I just found this in the documentation. So, maybe it's expected that subcollections won't be preserved.

    "Tags are portable, but collections are not. Copying items between Zotero libraries (My Library and group libraries) will transfer their tags, but not their collection placements. Both organizational methods have unique advantages and features. Experiment with both to see what works best for your own workflow. "
  • No, that's not relevant — that's just explaining a conceptual difference between tags and collections from the perspective of items. When you drag collections themselves, they're transferred.

    Again, the debug output you provide was generated midway through the copying, before collections would've copied, so I can't tell you why that didn't happen for you. But currently cross-library drags are performed in a single operation, and I'd guess that something is timing out for you. We're planning to change it in a future version to better handle copying of a large number of items and collections.
  • Dang on the debug. I wondered about whether I was submitting too soon during the debug process. But the instructions on the Zotero site on how to run a debug are not clear and suggest that one should submit immediately after starting the process. As a web programmer, I thought the didn't make sense, but I followed the instructions as best as I could interpret them. Notice that #3 in the instructions says "Before doing anything else...", which I interpreted as immediately. I thought that perhaps the debug was smart enough to wait till the end of the current process and then submit. The instructions should say something like, "monitor the debug window until the process complete. Once it is completed, return to Help →Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org." Make sense?

    1. In the Help menu, go to Debug Output Logging and select Enable, or use “Restart with Logging Enabled…” to generate debug output from Zotero startup. (If you're not able to access the Help menu, see Reporting Startup Errors instead.)

    2. Immediately perform the relevant action (syncing, saving, importing, etc.).

    3. Before doing anything else, return to Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID (e.g., “D12345678”). Click “Copy to Clipboard” and paste the Debug ID into your forum thread.

    As for the main issue, i.e. sub-collections not showing up when the parent us dragged, my guess is you're right, that it is a timing issue. I noticed that when I dragged individual sub-collections, the ones with only a few items were copied almost immediately into the new group, but ones with more than 50 items often failed to copy the sub-collection even after 15 minutes. If I exited Zotero and redid the drag, sometimes it would copy, and other times not. I was eventually able to drag all the sub-collections successfully, but on some I had to restart Zotero and redrag several times before they successfully copied.
Sign In or Register to comment.