Is Ieee xplore pdf download broken?

Hi,
Since recently, pdfs are no longer automatically downloaded from IEEE xplore.

For example, the article https://ieeexplore.ieee.org/document/1085344 doesn't work even though I'm logged in at the ieee xplore website and do get the pdf when I click the pdf logo on the page.
While loading the pdf, the zotero extension icon temporarily changes to a pdf icon, but when the pdf is fully downloaded, the icon changes back to a page-with-text icon.

Articles with open access available, such as https://ieeexplore.ieee.org/document/1085341 (from the same issue) do work, downloading the pdf from a different source.

Report ID: 1951569465

Best regards,

Paul
  • works for me (though can't test for that paper, to which I don't have access). How exactly is your access to IEEE managed? Is that an individual subscription? We'd always test with IP-based subscriptions, so login may work differently and is hard for us to test.
  • Hi,
    Yes, it's an individual subscription. It used to work for years, but of course this can be a result of changes on the IEEE end of the chain.
    Is there any way I can provide more detailed information that is helpful?

    Paul
  • edited 25 days ago
    Are you saying you get a red X next to the PDF entry in the save popup, or does a PDF entry not show up in the popup at all?

    If the former, can you provide a Debug ID (different from a Report ID) from Zotero for a save attempt on an article page for which the PDF download fails?

    If the latter, we'd want a Debug ID from the Zotero Connector for the save.
  • Hi,
    The pdf entry does not show up at all, so option #2.

    I opened the pdf from https://ieeexplore.ieee.org/document/7797450.
    While opening the pdf, the zotero icon briefly changes to a pdf icon.
    While viewing the pdf, the zotero toolbar icon was no longer a pdf icon, but a page with b&w text. Do you agree that this should be a pdf icon?
    Only a 'journal article' item was added to the database, without pdf.
    The Debug ID is D1629262736

    Paul
  • Are you saying that you're clicking Save to Zotero while viewing the PDF or while on the article page? You should be testing on the article page.
    Do you agree that this should be a pdf icon?
    On sites with URL patterns that include ids, Zotero can sometimes use a translator even when you're viewing a PDF, and when that's the case you'll see a non-PDF icon. You can see the translator being used by hovering over the save button, and if you right-click on it you'll likely still see "Save to Zotero (PDF)" as an option. But running the translator while viewing the PDF doesn't always work as reliably as the article page.
  • Ok, I assumed that clicking save from the pdf was more convincing since it 'proves' I actually have access. Saving from the article page fails the same way as what I'm experiencing when you're not logged in properly.
    I just wanted to exclude a login problem from the possible causes.

    On the article page:
    Hovering over the zotero plugin icon I get: 'save to zotero (IEEE Xplore)'
    A new artice item is added to the database, without pdf.
    The Debug ID is D1081232506.

    Paul
  • I've had the same problem.

    I'm with an institutional subscription. PDF download used to work.

    Debug ID: D1305078965
  • I am having the same issue.

    I am using institutional login to access IEEE Xplore, and I tried initially on Linux trough a proxy (it used to work); then I tried on Windows from within the institution's network, and the issue remains the same.

    The Zotero button doesn't show any PDF icon, and when I use the "Find Available PDF" option it says no PDF found, even when I am able to download it from IEEE Xplore web page.

    I think IEEE changed something on their side and it broke the Zotero connector.

    Thanks,

    Julio
  • I've pushed a new version of the IEEE Xplore translator that fixes PDF downloads for me. Your Zotero Connector should auto-update within 24 hours, or you can update manually by clicking Update Translators in the Advanced pane of the Zotero Connector preferences.

    @adamsmith, do you get a .pdf URL or a getPDF.jsp URL for the attachment? At least for me, via a web-based proxy, the iframe now serves the PDF via the latter, which the translator wasn't expecting.
  • Sorry, that's the URL of the PDF button. If you check the Network pane in the devtools, you can see the text/html response to that, which should include an iframe that contains another URL, which itself returns application/pdf.
  • Great, I just tested it on Firefox on Linux, through a proxy and it worked after restarting the browser a couple of times.

    Thank you!
Sign In or Register to comment.