Sync Timeout

I've suddenly started having sync issues and am regularly getting the "Request Timed out after 60000ms" message. I'm on a work network with Windows 10 but don't think anything has changed recently.

Report ID: 262389459

Debug ID: D1756369917

many thanks,
  • Further to this issue - This afternoon I was able to sync the library on my Microsoft Surface (Windows 10) with the web library using a non-work network. However, I've just tried to sync my library on my Macbook using my home network and I'm getting the same error.
    So now I have 4 versions of my library at various stages of syncing:

    Web library 12432 references
    Microsoft surface 12432 references
    Macbook 12442 references - this is the one I last edited some imported references and is the correct version
    Work computer 17xxx references - I imported some searches here with a view to editing at home

    Seems I might just need to somehow reset the sync register with the macbook as the primary source?

  • No, don't reset anything. We're investigating.
  • Don't worry, I won't :-)

  • Can you provide a Debug ID for another sync where this happens, for comparison?
  • This is on my Macbook using home network

    MacOS Catalina 10.15.2

  • Are you still seeing this today?
  • I tried it first thing on the work computer, which is the one furthest out of sync, and something happened in that some references that I'd deleted on the other computer were removed but then I got the same message.
    Currently trying again and the arrow has been going round for about 10 mins but nothing seems to be changing references wise but no error either as yet
  • So, it sat there for a couple of hours appearing to sync but nothing happening. I decided to close Zotero and got an error message telling me I had a corrupted logins database and to remove 3 files from the profile directory. I've done that, reset the sync login information and it's now syncing. Unfortunately it's syncing the wrong way in that the larger list on my desktop machine is syncing to the web, it must think that's the newer version of my library but no-drama if it gets everything back in sync - better than losing stuff.

    Thanks, Andy
  • I spoke too soon - it synced a few hundred references and then gave the same timeout error :-(
  • While this shouldn't happen, start by emptying your trash, and then sync again and provide another Debug ID if it's still failing for you.
  • It actually just managed to sync, albeit with a few hiccups. I now have all the desktop PC refs synced to the web (again). I'm just going through and finding the ones I wanted to keep (having done it once it's relatively quick) and I'll see how it goes once I delete the ones I don't want. At that point I'll empty the trash and see if it syncs - fingers crossed!
  • After editing the list I emptied the trash (didn't realise there were quite so many in there but might be they accummulated with all the stuffing around) then synced - woohoo it worked!

    I'll make sure I empty it more frequently from now on :-)

    Thanks for all your help

  • OK, great. Zotero will empty the trash for you automatically, but if you find yourself with large numbers of items in there you might want to reduce the number of days before items are auto-deleted from the General pane of the preferences.
Sign In or Register to comment.