Primo RIS export rejected by Zotero (error message)

I am trying to export Primo "favorites" (list of pinned articles) to Zotero and I receive and error message.
I tried all encoding formats from the Primo scroll list: UTF-8 to Windows 1251, but they all turn the same error: the selected file is not in supported format.
can you please share your experience how to resolve the issue?
Thank you
  • Can you download the file, open it in a text editor (Notepad, TextEdit), and post a sample record here?
  • (and you want to use UTF-8 for import into Zotero whenever that's an option)
  • @adamsmith: tried all four, including UTF-8, but same error message by Zotero
    @dstillman: here the text editor info, after I open with (I am on Mac):
  • The contents of the file are just "undefined"? That's obviously not a valid file, so there's nothing we can do about that.
  • if it actually says undefined as the sole content of the RIS file, that indicates a Primo bug. Obviously Zotero can't import "undefined" as a bibliographic reference ;)

    I'd contact the institution running that catalog -- focus on the RIS export part rather than Zotero in your error report. Mentioning Zotero can confuse things and the problem here really doesn't have anything to do with it -- it's just broken RIS export.
  • it worked.
    i am not sure, what i did wrong. apologies for taking your time.
    the RIS file in the text editor now shows the data, instead of "undefined" and it imports in Zotero.
    I wish, I was able to locate what I am doing wrong before
Sign In or Register to comment.